summaryrefslogtreecommitdiff
path: root/Build/source/texk/upmendex/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/texk/upmendex/Makefile.am
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/upmendex/Makefile.am')
-rw-r--r--Build/source/texk/upmendex/Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/Build/source/texk/upmendex/Makefile.am b/Build/source/texk/upmendex/Makefile.am
new file mode 100644
index 00000000000..8f1aa54f996
--- /dev/null
+++ b/Build/source/texk/upmendex/Makefile.am
@@ -0,0 +1,62 @@
+## $Id$
+## Makefile.am for the TeX Live subdirectory texk/upmendex/
+##
+## Copyright 2015-2019 Karl Berry <tex-live@tug.org>
+## Copyright 2010-2015 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+AM_CPPFLAGS = $(KPATHSEA_INCLUDES) $(ICU_INCLUDES)
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+bin_PROGRAMS = upmendex
+
+upmendex_SOURCES = \
+ convert.c \
+ exkana.h \
+ exvar.h \
+ fread.c \
+ fwrite.c \
+ kana.h \
+ kp.c \
+ kp.h \
+ ktable.h \
+ main.c \
+ mendex.h \
+ version.h \
+ pageread.c \
+ qsort.c \
+ qsort.h \
+ sort.c \
+ styfile.c \
+ var.h
+
+# Force Automake to use CXXLD for linking
+nodist_EXTRA_upmendex_SOURCES = dummy.cxx
+
+$(upmendex_OBJECTS): $(KPATHSEA_DEPEND) $(ICU_DEPEND)
+
+LDADD = $(KPATHSEA_LIBS) $(ICU_LIBS) $(PTHREAD_LIB) $(ICU_LIBS_EXTRA)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+## Rebuild libsicuxxx
+@ICU_RULE@
+
+EXTRA_DIST = \
+ COPYRIGHT
+
+## Eventually delete these files
+##
+EXTRA_DIST += \
+ indexsty \
+ upmendex.ja.txt
+
+## Tests
+##
+TESTS = tests/upmendex.test
+EXTRA_DIST += $(TESTS)
+
+## tests/upmendex.test
+EXTRA_DIST += tests/foo.idx tests/foo.ind \
+ tests/uni.idx tests/uni.dict tests/uni.ist tests/uni.ind
+DISTCLEANFILES = foo.* uni.*