summaryrefslogtreecommitdiff
path: root/Build/source/texk/ttfdump/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:15:32 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:15:32 +0000
commitd7f8ab6ea1a683492b985013a541ab11e33b9f73 (patch)
treea8b719cba4c45e2e308b53ebbd0ebb313a7cbf36 /Build/source/texk/ttfdump/Makefile.am
parent9d502c516fe61658f540e6b98621632b91deb53c (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12458 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/ttfdump/Makefile.am')
-rw-r--r--Build/source/texk/ttfdump/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/Build/source/texk/ttfdump/Makefile.am b/Build/source/texk/ttfdump/Makefile.am
new file mode 100644
index 00000000000..4866bbf9a91
--- /dev/null
+++ b/Build/source/texk/ttfdump/Makefile.am
@@ -0,0 +1,71 @@
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+## We want to distribute the whole subdirectories.
+##
+## With current automake (1.10.2) 'make distcheck' fails when
+## DISTFILES contains a directory and files in that directory.
+EXTRA_DIST = docs include libttf src
+
+INCLUDES = -I$(top_srcdir)/include $(KPATHSEA_INCLUDES)
+
+noinst_LIBRARIES = libttf.a
+
+nodist_libttf_a_SOURCES = \
+ libttf/cmap.c \
+ libttf/cvt.c \
+ libttf/disasm.c \
+ libttf/font.c \
+ libttf/fpgm.c \
+ libttf/gasp.c \
+ libttf/gcache.c \
+ libttf/glyf.c \
+ libttf/gstate.c \
+ libttf/hdmx.c \
+ libttf/head.c \
+ libttf/hhea.c \
+ libttf/hmtx.c \
+ libttf/interp.c \
+ libttf/kern.c \
+ libttf/loca.c \
+ libttf/ltsh.c \
+ libttf/maxp.c \
+ libttf/name.c \
+ libttf/os2.c \
+ libttf/pclt.c \
+ libttf/post.c \
+ libttf/prep.c \
+ libttf/stack.c \
+ libttf/tabledir.c \
+ libttf/ttc.c \
+ libttf/ttfread.c \
+ libttf/ttfutil.c \
+ libttf/vdmx.c \
+ libttf/vhea.c \
+ libttf/vmtx.c
+
+## The library doesn't actually depend on kpathsea, but this way
+## kpathsea is rebuilt before compiling ttfdump (I hope).
+libttf_a_DEPENDENCIES = $(KPATHSEA_DEPEND)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
+bin_PROGRAMS = ttfdump
+
+nodist_ttfdump_SOURCES = src/ttfdump.c
+
+LDADD = libttf.a
+
+nodist_man1_MANS = docs/ttfdump.1
+
+## #############
+## Not yet used
+
+EXTRA_DIST += ILX NOTE README.bg5
+
+## #############
+## Eventually delete these files
+
+EXTRA_DIST += Makefile.in.orig configure.in.orig
+