summaryrefslogtreecommitdiff
path: root/Build/source/texk/ttfdump/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-12-01 13:24:38 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-12-01 13:24:38 +0000
commit3131715fb5bce44da6c7584315237731aa752eba (patch)
treeb4e748ed3b19d603c4ac1b29f33340c196003e0e /Build/source/texk/ttfdump/Makefile.am
parent9417d53067c450b541cecd8c3ae224e5d17b8e54 (diff)
ttfdump: Added functionality
- do not segfault for fonts without loca table - allow cmap subtables with format 8, 10, 12, and 13 - handle GPOS and GSUB tables - additional tests git-svn-id: svn://tug.org/texlive/trunk@24713 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/ttfdump/Makefile.am')
-rw-r--r--Build/source/texk/ttfdump/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/Build/source/texk/ttfdump/Makefile.am b/Build/source/texk/ttfdump/Makefile.am
index e5d7547ca8a..018623bc1d8 100644
--- a/Build/source/texk/ttfdump/Makefile.am
+++ b/Build/source/texk/ttfdump/Makefile.am
@@ -12,9 +12,12 @@ noinst_LIBRARIES = libttf.a
libttf_a_SOURCES = \
include/gcache.h \
+ include/gpos.h \
include/gstate.h \
+ include/gsub.h \
include/loadtable.h \
include/os2_P.h \
+ include/otftables.h \
include/protos.h \
include/tables.h \
include/ttc.h \
@@ -28,7 +31,9 @@ libttf_a_SOURCES = \
libttf/gasp.c \
libttf/gcache.c \
libttf/glyf.c \
+ libttf/gpos.c \
libttf/gstate.c \
+ libttf/gsub.c \
libttf/hdmx.c \
libttf/head.c \
libttf/hhea.c \
@@ -39,6 +44,7 @@ libttf_a_SOURCES = \
libttf/maxp.c \
libttf/name.c \
libttf/os2.c \
+ libttf/otfcommon.c \
libttf/pclt.c \
libttf/post.c \
libttf/prep.c \
@@ -78,8 +84,15 @@ TESTS = tests/ttfdump.test
EXTRA_DIST += $(TESTS)
DISTCLEANFILES =
## tests/ttfdump.test
-EXTRA_DIST += tests/FonetikaDaniaIwonaeRegular.ttf tests/ttfdump.glyf tests/ttfdump.head
-DISTCLEANFILES += FonetikaDaniaIwonaeRegular.ttf ttfdump.glyf ttfdump.head
+EXTRA_DIST += \
+ tests/FonetikaDaniaIwonaeRegular.ttf \
+ tests/ttfdump.glyf \
+ tests/ttfdump.gpos \
+ tests/ttfdump.gsub \
+ tests/ttfdump.head
+DISTCLEANFILES += \
+ FonetikaDaniaIwonaeRegular.ttf \
+ ttftest.*
## Not used
##