summaryrefslogtreecommitdiff
path: root/Build/source/texk/ttf2pk2/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-05-02 13:18:14 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-05-02 13:18:14 +0000
commit2ba98f9a00f1b34455b12ef44c361154b48000c6 (patch)
tree5dd3ffba80490ec11a173f38f8a8f52277ac4509 /Build/source/texk/ttf2pk2/Makefile.am
parent9b5f1f3915e6c11001ef9c48efd372e93cbf7ab3 (diff)
Add texk/ttf2pk2 (ttf2pk-frretype2), at the moment not built by default
git-svn-id: svn://tug.org/texlive/trunk@22282 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/ttf2pk2/Makefile.am')
-rw-r--r--Build/source/texk/ttf2pk2/Makefile.am97
1 files changed, 97 insertions, 0 deletions
diff --git a/Build/source/texk/ttf2pk2/Makefile.am b/Build/source/texk/ttf2pk2/Makefile.am
new file mode 100644
index 00000000000..e33e1588bf8
--- /dev/null
+++ b/Build/source/texk/ttf2pk2/Makefile.am
@@ -0,0 +1,97 @@
+## Makefile.am for the TeX Live subdirectory texk/ttf2pk2/
+##
+## Copyright (C) 2011 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+INCLUDES = -I$(top_srcdir)/include $(KPATHSEA_INCLUDES) $(FREETYPE2_INCLUDES)
+AM_CPPFLAGS = -DHAVE_LIBKPATHSEA
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+bin_PROGRAMS = ttf2pk ttf2tfm
+
+common_sources = \
+ errormsg.c \
+ errormsg.h \
+ filesrch.c \
+ filesrch.h \
+ ligkern.c \
+ ligkern.h \
+ newobj.c \
+ newobj.h \
+ parse.c \
+ parse.h \
+ subfont.c \
+ subfont.h \
+ texenc.c \
+ texenc.h \
+ ttfenc.c \
+ ttfenc.h
+
+ttf2pk_SOURCES = \
+ $(common_sources) \
+ pklib.c \
+ pklib.h \
+ ttf2pk.c \
+ ttflib.c \
+ ttflib.h
+
+ttf2tfm_SOURCES = \
+ $(common_sources) \
+ case.c \
+ case.h \
+ tfmaux.c \
+ tfmaux.h \
+ ttf2tfm.c \
+ ttf2tfm.h \
+ ttfaux.c \
+ ttfaux.h \
+ vplaux.c \
+ vplaux.h
+
+$(ttf2pk_OBJECTS) $(ttf2tfm_OBJECTS): config.force
+
+config.force: $(KPATHSEA_DEPEND) $(FREETYPE2_DEPEND)
+ echo timestamp >config.force
+ $(SHELL) ./config.status --recheck
+
+DISTCLEANFILES = config.force
+
+LDADD = $(KPATHSEA_LIBS) $(FREETYPE2_LIBS) $(ZLIB_LIBS)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+## Rebuild libfreetype
+@FREETYPE2_RULE@
+
+dist_man1_MANS = ttf2pk.1 ttf2tfm.1
+
+EXTRA_DIST = data
+
+# in case of an SVN repository
+dist-hook:
+ rm -rf `find $(distdir) -name .svn`
+
+## Tests.
+##
+TESTS = tests/ttf2pk.test
+EXTRA_DIST += $(TESTS)
+## tests/ttf2pk.test
+EXTRA_DIST += tests/GenR102.ttf tests/gentium-ec.enc tests/ttf2pk.cfg tests/ttfonts.map
+DISTCLEANFILES += GenR-ec.vpl GenR102-ec.*
+
+## Not used
+##
+EXTRA_DIST += \
+ BUGS \
+ MakeSub.in \
+ Makefile.dm \
+ dvidrv.btm \
+ dvidrv.doc \
+ emdir.c \
+ emdir.h \
+ emtexdir.c \
+ emtexdir.h \
+ ttf2pk.doc
+