summaryrefslogtreecommitdiff
path: root/Build/source/texk/psutils/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-12-03 12:13:36 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-12-03 12:13:36 +0000
commit6c95206204a22fa0f39833b36c446fae569c2eb4 (patch)
tree4d3691c9ba9b979b7d04f022d92a20c3507f2791 /Build/source/texk/psutils/configure.ac
parentef888e5b75caca5afa1021d6eb57437019ea8481 (diff)
psutils: Use getopt() from kpathsea and move from utils/ to texk/
git-svn-id: svn://tug.org/texlive/trunk@32305 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/psutils/configure.ac')
-rw-r--r--Build/source/texk/psutils/configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/Build/source/texk/psutils/configure.ac b/Build/source/texk/psutils/configure.ac
new file mode 100644
index 00000000000..561c6834591
--- /dev/null
+++ b/Build/source/texk/psutils/configure.ac
@@ -0,0 +1,35 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_include([version.ac])[] dnl define psutils_version
+AC_INIT([psutils (TeX Live)], psutils_version, [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([psutils-]psutils_version[/psutil.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+KPSE_COMMON([psutils])
+
+AC_CONFIG_HEADERS([config.h])
+
+AH_BOTTOM([#include <kpathsea/getopt.h>])
+
+KPSE_KPATHSEA_FLAGS
+KPSE_PAPER_FLAGS
+
+KPSE_COND_WIN32_WRAP
+
+AC_SUBST([PSUTILS_TREE], [psutils-]psutils_version)
+
+AC_CONFIG_FILES([Makefile])
+
+AC_CONFIG_LINKS([extractres.pl:psutils-]psutils_version[/extractres])
+AC_CONFIG_LINKS([includeres.pl:psutils-]psutils_version[/extractres])
+AC_CONFIG_LINKS([psjoin.pl:psutils-]psutils_version[/psjoin])
+
+AC_OUTPUT