summaryrefslogtreecommitdiff
path: root/Build/source/texk/makejvf/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2010-04-11 00:28:06 +0000
committerKarl Berry <karl@freefriends.org>2010-04-11 00:28:06 +0000
commit001b7975ce276ec6e72bf2b317cef8afe92c2948 (patch)
tree3c73cdd11c93462911cb416a231af743f48d5368 /Build/source/texk/makejvf/Makefile.am
parent22d2dd3a9e8cc227f8d51b2fe8cf1734c2844959 (diff)
add ptex from Akira, Norbert, and jTeX group; ptex not actually built by default yet
git-svn-id: svn://tug.org/texlive/trunk@17797 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/makejvf/Makefile.am')
-rw-r--r--Build/source/texk/makejvf/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Build/source/texk/makejvf/Makefile.am b/Build/source/texk/makejvf/Makefile.am
new file mode 100644
index 00000000000..cd96a498a82
--- /dev/null
+++ b/Build/source/texk/makejvf/Makefile.am
@@ -0,0 +1,24 @@
+## Makefile.am for the TeX Live subdirectory texk/makejvfk/
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+INCLUDES = $(KPATHSEA_INCLUDES) $(PTEXENC_INCLUDES)
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+bin_PROGRAMS = makejvf
+
+makejvf_SOURCES = \
+ main.c makejvf.h tfmread.c tool.c write.c
+
+$(makejvf_OBJECTS): $(KPATHSEA_DEPEND) $(PTEXENC_DEPEND)
+
+LDADD = $(PTEXENC_LIBS) $(KPATHSEA_LIBS)
+
+## Rebuild libkpathsea & libptexenc
+@PTEXENC_RULE@
+
+EXTRA_DIST = COPYRIGHT COPYRIGHT.jis Changes.txt README.txt
+