summaryrefslogtreecommitdiff
path: root/Build/source/texk/lcdf-typetools/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2008-02-17 19:29:39 +0000
committerKarl Berry <karl@freefriends.org>2008-02-17 19:29:39 +0000
commitfc3b5d4d4f684baa6216685a0696efb853141529 (patch)
tree0694ed01c09b3c97fcd64453e2c1f647a3fb31ad /Build/source/texk/lcdf-typetools/Makefile.am
parent5fc0a693ca037d37d815b00c49660c138b332224 (diff)
move lcdf-typetools to texk and update to 2.66
git-svn-id: svn://tug.org/texlive/trunk@6662 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/lcdf-typetools/Makefile.am')
-rw-r--r--Build/source/texk/lcdf-typetools/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/Build/source/texk/lcdf-typetools/Makefile.am b/Build/source/texk/lcdf-typetools/Makefile.am
new file mode 100644
index 00000000000..d03fd0071ca
--- /dev/null
+++ b/Build/source/texk/lcdf-typetools/Makefile.am
@@ -0,0 +1,76 @@
+## Process this file with automake to produce Makefile.in
+AUTOMAKE_OPTIONS = foreign check-news
+
+SUBDIRS = liblcdf libefont @SELECTED_SUBDIRS@
+DIST_SUBDIRS = liblcdf libefont cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1reencode t1testpage ttftotype42
+
+pkgdata_DATA = glyphlist.txt texglyphlist.txt 7t.enc
+
+EXTRA_DIST = \
+ ONEWS \
+ lcdf-typetools.spec \
+ include/lcdf/bezier.hh \
+ include/lcdf/clp.h \
+ include/lcdf/error.hh \
+ include/lcdf/filename.hh \
+ include/lcdf/globmatch.hh \
+ include/lcdf/hashmap.hh include/lcdf/hashmap.cc \
+ include/lcdf/inttypes.h \
+ include/lcdf/landmark.hh \
+ include/lcdf/md5.h \
+ include/lcdf/permstr.hh \
+ include/lcdf/point.hh \
+ include/lcdf/slurper.hh \
+ include/lcdf/straccum.hh \
+ include/lcdf/string.hh \
+ include/lcdf/strtonum.h \
+ include/lcdf/transform.hh \
+ include/lcdf/vector.hh include/lcdf/vector.cc \
+ include/efont/afm.hh \
+ include/efont/afmparse.hh \
+ include/efont/afmw.hh \
+ include/efont/amfm.hh \
+ include/efont/cff.hh \
+ include/efont/encoding.hh \
+ include/efont/findmet.hh \
+ include/efont/metrics.hh \
+ include/efont/otf.hh \
+ include/efont/otfcmap.hh \
+ include/efont/otfdata.hh \
+ include/efont/otfgpos.hh \
+ include/efont/otfgsub.hh \
+ include/efont/otfname.hh \
+ include/efont/otfos2.hh \
+ include/efont/otfpost.hh \
+ include/efont/pairop.hh \
+ include/efont/psres.hh \
+ include/efont/t1bounds.hh \
+ include/efont/t1cs.hh \
+ include/efont/t1csgen.hh \
+ include/efont/t1font.hh \
+ include/efont/t1interp.hh \
+ include/efont/t1item.hh \
+ include/efont/t1mm.hh \
+ include/efont/t1rw.hh \
+ include/efont/t1unparser.hh \
+ include/efont/ttfcs.hh \
+ include/efont/ttfhead.hh \
+ glyphlist.txt \
+ texglyphlist.txt \
+ 7t.enc
+
+liblcdf libefont:
+ cd $@ && $(MAKE)
+libefont: liblcdf
+cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1reencode t1testpage ttftotype42: liblcdf libefont
+ cd $@ && $(MAKE)
+
+srclinks:
+ cd liblcdf && $(MAKE) srclinks
+ cd libefont && $(MAKE) srclinks
+
+versionize:
+ perl -pi -e 's/^\.ds V.*/.ds V $(VERSION)/;' $(top_srcdir)/cfftot1/cfftot1.1 $(top_srcdir)/mmafm/mmafm.1 $(top_srcdir)/mmpfb/mmpfb.1 $(top_srcdir)/otfinfo/otfinfo.1 $(top_srcdir)/otftotfm/otftotfm.1 $(top_srcdir)/t1dotlessj/t1dotlessj.1 $(top_srcdir)/t1lint/t1lint.1 $(top_srcdir)/t1reencode/t1reencode.1 $(top_srcdir)/t1testpage/t1testpage.1 $(top_srcdir)/ttftotype42/ttftotype42.1
+ perl -pi -e 's/^(\U$(PACKAGE)\E) [\d.ab]+$$/$$1 $(VERSION)/;' $(top_srcdir)/README
+
+.PHONY: srclinks rpm liblcdf libefont cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1reencode t1testpage ttftotype42