summaryrefslogtreecommitdiff
path: root/Build/source/texk/lcdf-typetools/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 09:50:07 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 09:50:07 +0000
commit82150b6fc41b8a3446f2c6020ddf5625956dd708 (patch)
tree9234f85d00b9fd322b0986b62f09e355449190e6 /Build/source/texk/lcdf-typetools/Makefile.am
parent6b3b122ab7e6994e0b4c8d1299eb2c3462388542 (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12456 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/lcdf-typetools/Makefile.am')
-rw-r--r--Build/source/texk/lcdf-typetools/Makefile.am22
1 files changed, 17 insertions, 5 deletions
diff --git a/Build/source/texk/lcdf-typetools/Makefile.am b/Build/source/texk/lcdf-typetools/Makefile.am
index 69e545394aa..2bd02f2f2f6 100644
--- a/Build/source/texk/lcdf-typetools/Makefile.am
+++ b/Build/source/texk/lcdf-typetools/Makefile.am
@@ -1,8 +1,10 @@
## Process this file with automake to produce Makefile.in
-AUTOMAKE_OPTIONS = foreign check-news
+ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = liblcdf libefont @SELECTED_SUBDIRS@
-DIST_SUBDIRS = liblcdf libefont cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1reencode t1testpage ttftotype42
+DISTCHECK_CONFIGURE_FLAGS = --without-kpathsea
+
+SUBDIRS = $(SELECTED_SUBDIRS)
+DIST_SUBDIRS = liblcdf libefont cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1rawafm t1reencode t1testpage ttftotype42
pkgdata_DATA = glyphlist.txt texglyphlist.txt 7t.enc
@@ -62,7 +64,7 @@ EXTRA_DIST = \
liblcdf libefont:
cd $@ && $(MAKE)
libefont: liblcdf
-cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1reencode t1testpage ttftotype42: liblcdf libefont
+cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1rawafm t1reencode t1testpage ttftotype42: liblcdf libefont
cd $@ && $(MAKE)
srclinks:
@@ -74,4 +76,14 @@ versionize:
perl -pi -e 's/^(\U$(PACKAGE)\E) [\d.ab]+$$/$$1 $(VERSION)/;' $(top_srcdir)/README
perl -pi -e 's/^Version: [\d.ab]+$$/Version: $(VERSION)/;' $(top_srcdir)/lcdf-typetools.spec
-.PHONY: srclinks rpm liblcdf libefont cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1reencode t1testpage ttftotype42
+.PHONY: srclinks rpm liblcdf libefont cfftot1 mmafm mmpfb otfinfo otftotfm t1dotlessj t1lint t1rawafm t1reencode t1testpage ttftotype42
+
+## Required for integration into TeX Live build system
+##
+EXTRA_DIST += ac/withenable.ac
+
+## Eventually delete these files
+##
+
+EXTRA_DIST += Makefile.am.orig configure.ac.orig
+