summaryrefslogtreecommitdiff
path: root/Build/source/texk/lacheck/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2010-12-10 11:22:05 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2010-12-10 11:22:05 +0000
commit0a1e75ee98dd6caa88dd7566007ab4c6c8511544 (patch)
treeb8845646169c5d84821f476a5eaa490afbf2ff55 /Build/source/texk/lacheck/Makefile.am
parent7e8b4dc5ce744eed534c8aa93a8b503c80317c76 (diff)
texk/lacheck build: use orig source from ctan + patches
git-svn-id: svn://tug.org/texlive/trunk@20707 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/lacheck/Makefile.am')
-rw-r--r--Build/source/texk/lacheck/Makefile.am29
1 files changed, 16 insertions, 13 deletions
diff --git a/Build/source/texk/lacheck/Makefile.am b/Build/source/texk/lacheck/Makefile.am
index a3b9c05e491..a3070bf2302 100644
--- a/Build/source/texk/lacheck/Makefile.am
+++ b/Build/source/texk/lacheck/Makefile.am
@@ -1,36 +1,39 @@
## Makefile.am for the TeX Live subdirectory texk/lacheck/
##
-## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
ACLOCAL_AMFLAGS = -I ../../m4
+LACHECK_TREE = lacheck-$(REV)
+
+## We want to re-distribute the whole original lacheck source tree.
+EXTRA_DIST = $(LACHECK_TREE)
+## Patches applied to the original source tree
+EXTRA_DIST += $(LACHECK_TREE)-PATCHES
+
+# in case of an SVN repository
+dist-hook:
+ rm -rf `find $(distdir) -name .svn`
+
AM_CFLAGS = $(WARNING_CFLAGS)
bin_PROGRAMS = lacheck
-lacheck_SOURCES = lacheck.l
+lacheck_SOURCES = $(LACHECK_TREE)/lacheck.l
nodist_man1_MANS = lacheck.1
-lacheck.1: lacheck.man
+lacheck.1: $(LACHECK_TREE)/lacheck.man
sed -e "s!%%LACHECKREV%%!Release $(REV)!" \
- -e "s!%%LACHECKDATE%%!`date +%Y-%m-%d`!" \
-e "s!%%LACHECKPATH%%!lacheck!" $< > $@
-EXTRA_DIST = lacheck.man
-
CLEANFILES = lacheck.1
dist_check_SCRIPTS = lacheck.test
TESTS = lacheck.test
+TESTS_ENVIRONMENT = LACHECK_TREE=$(LACHECK_TREE)
-EXTRA_DIST += test.tex test.out
-
-CLEANFILES += test.xout
-
-## Not used
-##
-EXTRA_DIST += lacheck.hlp make_vms.com
+CLEANFILES += test.out