summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-12-07 13:04:51 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-12-07 13:04:51 +0000
commitd4aa787bcd1653b8870badb2daca7807c707b131 (patch)
tree57294f37e38a9bebef2fefd8840b88a295285e1f /Build/source/texk/kpathsea/Makefile.am
parent997df6b25d88565f035347d581ca699cbf2c5938 (diff)
freetype 2.5.4
git-svn-id: svn://tug.org/texlive/trunk@35761 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index 03c0cfab060..17ab473710a 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -220,15 +220,13 @@ stamp-kpathsea: Makefile paths.h
echo '/* collecting all public kpathsea headers. */'; \
for f in config.h paths.h $(direct_headers); do \
echo "#include <kpathsea/$$f>"; \
- done ) >kpathsea.tmp
- @if cmp -s kpathsea.h kpathsea.tmp 2>/dev/null; then \
+ done ) >kpathsea.tmp && \
+ if cmp -s kpathsea.h kpathsea.tmp 2>/dev/null; then \
echo "kpathsea.h is unchanged"; \
else \
- echo "cp kpathsea.tmp kpathsea.h"; \
+ echo "generated kpathsea.h"; \
cp kpathsea.tmp kpathsea.h; \
- fi
- rm -f kpathsea.tmp
- date >$@
+ fi && rm -f kpathsea.tmp && date >$@
EXTRA_DIST += bsnl.awk cnf-to-paths.awk