summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-30 15:14:16 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-30 15:14:16 +0000
commita815247064fb423e2d7d9db3d48022d1ca51035c (patch)
tree177f89d1f64296584f066fab0a431cfa0608591a /Build/source/texk/kpathsea/Makefile.am
parentdec877638c9dda1400697ea912b969ec6b3410f3 (diff)
build system: avoid GNU grep specific code
git-svn-id: svn://tug.org/texlive/trunk@14018 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index d80fff94c13..2643ac009a4 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -221,7 +221,11 @@ kpathsea.h: Makefile paths.h
echo '#include <kpathsea/c-auto.h>' >>$@
echo '#include <kpathsea/paths.h>' >>$@
(cd $(srcdir) && ls -1 *.h) \
- | grep -v '\(config\|paths\|kpathsea\|mingw32\|win32lib\)\.h' \
+ | grep -v 'config\.h' \
+ | grep -v 'paths\.h' \
+ | grep -v 'kpathsea\.h' \
+ | grep -v 'mingw32\.h' \
+ | grep -v 'win32lib\.h' \
| sed -e 's,^,#include <kpathsea/,' -e s',$$,>,' >>$@
DISTCLEANFILES = paths.h stamp-paths kpathsea.h