summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-22 07:26:00 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-06-22 07:26:00 +0000
commit330e84f85f4c230b385fdf2335888cbccb1eee26 (patch)
tree4b9bc6340864bd424202e872a3b84d1712ad9c2f /Build/source/texk/kpathsea/Makefile.am
parent63a8ebc9eb71c28299f568dc55f55c92ea09cd93 (diff)
enable compiler warnings
git-svn-id: svn://tug.org/texlive/trunk@13875 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index 8d2960289fc..890ce706742 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -10,6 +10,7 @@ SUBDIRS = . doc man
EXTRA_DIST = BUGS HIER PROJECTS README.CONFIGURE
INCLUDES = -I$(top_builddir)/.. -I$(top_srcdir)/..
+AM_CFLAGS = $(WARNING_CFLAGS)
lib_LTLIBRARIES = libkpathsea.la
@@ -49,7 +50,6 @@ libkpathsea_la_SOURCES = \
line.c \
magstep.c \
make-suffix.c \
- mingw32.c \
path-elt.c \
pathsearch.c \
proginit.c \
@@ -82,6 +82,10 @@ libkpathsea_la_SOURCES = \
xstat.c \
xstrdup.c
+if MINGW32
+libkpathsea_la_SOURCES += mingw32.c
+endif MINGW32
+
$(libkpathsea_la_SOURCES): paths.h
EXTRA_DIST += \