summaryrefslogtreecommitdiff
path: root/Build/source/texk/gregorio/gregorio-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2016-09-25 06:05:30 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2016-09-25 06:05:30 +0000
commitf77c54eb48f9abb742a0102243e04168e04f8d9f (patch)
treed39cc0f736eef5cd39e971f3834b6f521ddb00b4 /Build/source/texk/gregorio/gregorio-src/configure.ac
parent337eaca0d4cd1b1257bfd995e50bd4caac7565e9 (diff)
gregorio 4.2.0
git-svn-id: svn://tug.org/texlive/trunk@42143 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/gregorio/gregorio-src/configure.ac')
-rw-r--r--Build/source/texk/gregorio/gregorio-src/configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/Build/source/texk/gregorio/gregorio-src/configure.ac b/Build/source/texk/gregorio/gregorio-src/configure.ac
index ae522daf49f..81aaa70b9c4 100644
--- a/Build/source/texk/gregorio/gregorio-src/configure.ac
+++ b/Build/source/texk/gregorio/gregorio-src/configure.ac
@@ -1,5 +1,5 @@
dnl Gregorio
-dnl Copyright (C) 2006-2015 The Gregorio Project (see CONTRIBUTORS.md)
+dnl Copyright (C) 2006-2016 The Gregorio Project (see CONTRIBUTORS.md)
dnl
dnl This file is part of Gregorio.
dnl
@@ -16,8 +16,8 @@ dnl
dnl You should have received a copy of the GNU General Public License
dnl along with Gregorio. If not, see <http://www.gnu.org/licenses/>.
-AC_INIT([gregorio],[4.1.4],[https://github.com/gregorio-project/gregorio/issues],[gregorio],[http://gregorio-project.github.io/])
-FILENAME_VERSION="4_1_4"
+AC_INIT([gregorio],[4.2.0],[https://github.com/gregorio-project/gregorio/issues],[gregorio],[http://gregorio-project.github.io/])
+FILENAME_VERSION="4_2_0"
AC_SUBST(FILENAME_VERSION)
AC_DEFINE_UNQUOTED(FILENAME_VERSION, "$FILENAME_VERSION", [version suitable for file names])
MK=""
@@ -38,6 +38,8 @@ AC_PROG_YACC
AC_CHECK_TOOL([RC], [windres], [no])
AM_CONDITIONAL([HAVE_RC], [test x$RC != xno])
+AC_CHECK_ALIGNOF(uint32_t)
+
AX_CHECK_COMPILE_FLAG([-std=gnu89], [CFLAGS+=" -std=gnu89"])
dnl until flex gets their act together, use pedantic instead of pedantic-errors
AX_CHECK_COMPILE_FLAG([-pedantic], [CFLAGS+=" -pedantic"])
@@ -50,7 +52,6 @@ AX_CHECK_COMPILE_FLAG([-Wstrict-prototypes], [CFLAGS+=" -Wstrict-prototypes"])
AX_CHECK_COMPILE_FLAG([-Wdeclaration-after-statement], [CFLAGS+=" -Wdeclaration-after-statement"])
AX_CHECK_COMPILE_FLAG([-Wall], [CFLAGS+=" -Wall"])
AX_CHECK_COMPILE_FLAG([-Wextra], [CFLAGS+=" -Wextra"])
-CPPFLAGS+=" -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 "
AX_CHECK_LINK_FLAG([-Wl,-z,relro], [LDFLAGS+=" -Wl,-z,relro"])
AX_CHECK_LINK_FLAG([-Wl,-z,now], [LDFLAGS+=" -Wl,-z,now"])
AX_CHECK_LINK_FLAG([-fPIE], [LDFLAGS+=" -fPIE"])
@@ -96,7 +97,11 @@ AC_ARG_ENABLE([debug], AS_HELP_STRING([--enable-debug@<:@=sanitize,coverage@:>@]
AX_CHECK_COMPILE_FLAG([--coverage], [CFLAGS+=" --coverage"])
AX_CHECK_LINK_FLAG([--coverage], [LDFLAGS+=" --coverage"])
])
+ ], [
+ CPPFLAGS+=" -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 "
])
+], [
+ CPPFLAGS+=" -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 "
])
AC_CONFIG_HEADERS([src/config_.h])