summaryrefslogtreecommitdiff
path: root/Build/source/texk/gregorio/gregorio-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2016-02-09 02:13:53 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2016-02-09 02:13:53 +0000
commit77471d966e7252229e6379968b18a7ad789b56da (patch)
tree5e6ff026566c8f7443f132bb097e7325b7b5acee /Build/source/texk/gregorio/gregorio-src/configure.ac
parenta286a15b8e122724c858631a30ad23e0e9bff1a1 (diff)
gregorio 4.1.0-beta2
git-svn-id: svn://tug.org/texlive/trunk@39632 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/gregorio/gregorio-src/configure.ac')
-rw-r--r--Build/source/texk/gregorio/gregorio-src/configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/Build/source/texk/gregorio/gregorio-src/configure.ac b/Build/source/texk/gregorio/gregorio-src/configure.ac
index f7aab257a02..5db9cd0d130 100644
--- a/Build/source/texk/gregorio/gregorio-src/configure.ac
+++ b/Build/source/texk/gregorio/gregorio-src/configure.ac
@@ -16,8 +16,8 @@ dnl
dnl You should have received a copy of the GNU General Public License
dnl along with Gregorio. If not, see <http://www.gnu.org/licenses/>.
-AC_INIT([gregorio],[4.1.0-beta1],[gregorio-devel@gna.org])
-FILENAME_VERSION="4_1_0-beta1"
+AC_INIT([gregorio],[4.1.0-beta2],[gregorio-devel@gna.org])
+FILENAME_VERSION="4_1_0-beta2"
AC_SUBST(FILENAME_VERSION)
MK=""
AC_SUBST(MK)
@@ -82,6 +82,22 @@ AS_IF([test "x$with_kpathsea" = "xyes"], [
)
])
+AC_ARG_ENABLE([debug], AS_HELP_STRING([--enable-debug@<:@=sanitize,coverage@:>@], [Enable debugging options [with additional sanitize options].]), [
+ AS_IF([test "x$enableval" != "xno"], [
+ dnl AX_CHECK_COMPILE_FLAG([-g], [CFLAGS+=" -g"])
+ AX_CHECK_COMPILE_FLAG([-Og], [CFLAGS+=" -Og"], [
+ AX_CHECK_COMPILE_FLAG([-O0], [CFLAGS+=" -O0"])
+ ])
+ AS_IF([test "x$enableval" = "xsanitize"], [
+ AX_CHECK_COMPILE_FLAG([-fsanitize=address,undefined], [CFLAGS+=" -fsanitize=address,undefined"])
+ ])
+ AS_IF([test "x$enableval" = "xcoverage"], [
+ AX_CHECK_COMPILE_FLAG([--coverage], [CFLAGS+=" --coverage"])
+ AX_CHECK_LINK_FLAG([--coverage], [LDFLAGS+=" --coverage"])
+ ])
+ ])
+])
+
AC_CONFIG_HEADERS([src/config_.h])
AC_CONFIG_FILES([
Makefile