summaryrefslogtreecommitdiff
path: root/Build/source/texk/gregorio/gregorio-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2017-04-15 21:00:07 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2017-04-15 21:00:07 +0000
commit0dc292de52a3c273ade8e8eb97aa078ac2ea705f (patch)
tree3a093e56006d8fa644f364264293ec69b261aef4 /Build/source/texk/gregorio/gregorio-src/configure.ac
parent974de1d33abc6e3305f29e3f9e9ccf63809be26a (diff)
gregorio-5.0.0
git-svn-id: svn://tug.org/texlive/trunk@43809 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/gregorio/gregorio-src/configure.ac')
-rw-r--r--Build/source/texk/gregorio/gregorio-src/configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/Build/source/texk/gregorio/gregorio-src/configure.ac b/Build/source/texk/gregorio/gregorio-src/configure.ac
index e7d1c97fc26..9c7ce0b0b8d 100644
--- a/Build/source/texk/gregorio/gregorio-src/configure.ac
+++ b/Build/source/texk/gregorio/gregorio-src/configure.ac
@@ -16,8 +16,8 @@ dnl
dnl You should have received a copy of the GNU General Public License
dnl along with Gregorio. If not, see <http://www.gnu.org/licenses/>.
-AC_INIT([gregorio],[5.0.0-rc1],[https://github.com/gregorio-project/gregorio/issues],[gregorio],[http://gregorio-project.github.io/])
-FILENAME_VERSION="5_0_0-rc1"
+AC_INIT([gregorio],[5.0.0],[https://github.com/gregorio-project/gregorio/issues],[gregorio],[http://gregorio-project.github.io/])
+FILENAME_VERSION="5_0_0"
AC_SUBST(FILENAME_VERSION)
AC_DEFINE_UNQUOTED(FILENAME_VERSION, "$FILENAME_VERSION", [version suitable for file names])
MK=""
@@ -104,6 +104,17 @@ AC_ARG_ENABLE([debug], AS_HELP_STRING([--enable-debug@<:@=sanitize,coverage@:>@]
CPPFLAGS+=" -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 "
])
+AC_ARG_ENABLE([version-in-exe], AS_HELP_STRING([--disable-version-in-exe], [Disable version in executable name.]), [
+ AS_IF([test "x$enableval" != "xno"], [
+ GREGORIO_EXE_SUFFIX="-$FILENAME_VERSION"
+ ], [
+ GREGORIO_EXE_SUFFIX=""
+ ])
+], [
+ GREGORIO_EXE_SUFFIX="-$FILENAME_VERSION"
+])
+AC_SUBST(GREGORIO_EXE_SUFFIX)
+
AC_CONFIG_HEADERS([src/config_.h])
AC_CONFIG_FILES([
Makefile