summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvisvgm/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-25 11:07:49 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-25 11:07:49 +0000
commit4e88f0c77dd922b1aa8432f51de7bdc5c75036ae (patch)
treefdfcaf8994fc08aa75de88590eca0272aa38084d /Build/source/texk/dvisvgm/configure.ac
parent4ecb824241f9cfdeff51b1d2a5c70e504bcfa80c (diff)
build system: dlopen, FreeBSD, and libdl
git-svn-id: svn://tug.org/texlive/trunk@17552 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvisvgm/configure.ac')
-rw-r--r--Build/source/texk/dvisvgm/configure.ac31
1 files changed, 20 insertions, 11 deletions
diff --git a/Build/source/texk/dvisvgm/configure.ac b/Build/source/texk/dvisvgm/configure.ac
index 6ab273d890f..59bc01124ed 100644
--- a/Build/source/texk/dvisvgm/configure.ac
+++ b/Build/source/texk/dvisvgm/configure.ac
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
@@ -40,6 +40,8 @@ AC_SEARCH_LIBS([sqrt], [m])
AC_CHECK_FUNCS([ftime gettimeofday])
AC_CHECK_HEADERS([sys/time.h sys/timeb.h])
+KPSE_CHECK_WIN32
+
KPSE_KPATHSEA_FLAGS
KPSE_ZLIB_FLAGS
KPSE_FREETYPE2_FLAGS
@@ -74,16 +76,23 @@ if test "x$with_system_libgs" = xyes; then
else
libgs_mode=load
LIBGS_INCLUDES=
- LIBGS_LIBS=-ldl
- KPSE_ADD_FLAGS([libgs])
- AC_CHECK_HEADER([dlfcn.h])
- AC_CHECK_FUNC([dlopen])
- if test "x$ac_cv_header_dlfcn_h:$ac_cv_func_dlopen" != xyes:yes; then
- libgs_mode=no
- KPSE_RESTORE_FLAGS
- AC_DEFINE([DISABLE_GS], 1,
- [Set to 1 if PostScript support should be disabled.])
- LIBGS_LIBS=
+ LIBGS_LIBS=
+ # Windows (native or MinGW32) has neither <dlfcn.h> nor dlopen().
+ if test "x$kpse_cv_have_win32" = xno; then
+ # FreeBSD neither has nor requires libdl.
+ AC_SEARCH_LIBS([dlopen], [dl])
+ AS_CASE([$ac_cv_search_dlopen],
+ [no | "none required"], [],
+ [LIBGS_LIBS=$ac_cv_search_dlopen])
+ AC_CHECK_HEADER([dlfcn.h])
+ AC_CHECK_FUNC([dlopen])
+ if test "x$ac_cv_header_dlfcn_h:$ac_cv_func_dlopen" != xyes:yes; then
+ libgs_mode=no
+ KPSE_RESTORE_FLAGS
+ AC_DEFINE([DISABLE_GS], 1,
+ [Set to 1 if PostScript support should be disabled.])
+ LIBGS_LIBS=
+ fi
fi
fi
AC_SUBST([LIBGS_INCLUDES])