summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvisvgm/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2018-03-11 22:12:17 +0000
committerKarl Berry <karl@freefriends.org>2018-03-11 22:12:17 +0000
commit15c3f6ef22d5c7e84000448b07428446894499b8 (patch)
tree14285cecd23364306c24a6e5e6ee31997d3e35d6 /Build/source/texk/dvisvgm/configure.ac
parent896f6a972a3bb8d5d157e92626dcf02c4ed2dd3d (diff)
have_libgs for non-native-tl builds
git-svn-id: svn://tug.org/texlive/trunk@46927 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvisvgm/configure.ac')
-rw-r--r--Build/source/texk/dvisvgm/configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/Build/source/texk/dvisvgm/configure.ac b/Build/source/texk/dvisvgm/configure.ac
index 835da7b8362..1f73c8c77f4 100644
--- a/Build/source/texk/dvisvgm/configure.ac
+++ b/Build/source/texk/dvisvgm/configure.ac
@@ -63,6 +63,9 @@ have_libgs=yes
AC_CHECK_HEADER([ghostscript/iapi.h],
[AC_CHECK_LIB(gs, gsapi_revision,, [have_libgs=no])],
[have_libgs=no])
+if test "x$have_libgs" = xyes; then
+ HAVE_LIBGS=1
+fi
AS_IF([test "x$have_libgs" = "xno"],
# Ghostscript not found, check for dlopen
[AC_CHECK_LIB(dl, dlopen,,
@@ -106,7 +109,7 @@ else
[gsversion=`cat gsversion`], [gsversion=], [gsversion=unknown])
AC_MSG_RESULT("$gsversion")
rm -f gsversion
- if test -z "$gsversion" || "$gsversion" -lt 831; then
+ if test -z "$gsversion" || test "$gsversion" -lt 831; then
# current Ghostscript API was introduced in version 8.31
# older versions are not supported
AC_DEFINE(DISABLE_GS, 1, [Set to 1 if PostScript support should be disabled])