summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2008-05-09 23:09:19 +0000
committerKarl Berry <karl@freefriends.org>2008-05-09 23:09:19 +0000
commitfc0d5bd5d823bb4ad11757609ea705390e975479 (patch)
tree87164107acc12ecd361a1eae24c9dfc69f95c59e /Build/source/texk/dvipng/configure.ac
parenteeb60f2336ed350f714dbbfc58bc224afe8ad333 (diff)
dvipng 1.10 (but reverting configure.ac to ours) from savannah.nongnu.org
git-svn-id: svn://tug.org/texlive/trunk@7995 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvipng/configure.ac')
-rw-r--r--Build/source/texk/dvipng/configure.ac20
1 files changed, 6 insertions, 14 deletions
diff --git a/Build/source/texk/dvipng/configure.ac b/Build/source/texk/dvipng/configure.ac
index 3cf49b7ad91..7bef5380434 100644
--- a/Build/source/texk/dvipng/configure.ac
+++ b/Build/source/texk/dvipng/configure.ac
@@ -2,7 +2,7 @@
# the dvipng maintainers for it.
# Process this file with autoconf to produce a configure script.
-AC_INIT([dvipng], [1.9], [dvipng@nongnu.org])
+AC_INIT([dvipng], [1.10], [dvipng@nongnu.org])
AC_CONFIG_SRCDIR([dvipng.c])
AC_ARG_ENABLE(debug,
@@ -28,9 +28,12 @@ AC_ARG_WITH(gs,
GS=no
else
AC_PATH_PROG(GS,["$withval"])
+ dnl --skip, karl GS_CHECK_DEVICES
fi],
[AC_CHECK_PROG(GS,gs,gs)
- if test -z "$GS"; then
+ if test -n "$GS"; then
+ ; dnl --skip, karl GS_CHECK_DEVICES
+ else
GS="gs"
AC_MSG_WARN([Cannot find GhostScript in your PATH])
fi
@@ -51,17 +54,6 @@ AC_DEFUN([AC_GS_HAS_DEVICE],
fi
])
-GS_WARN=""
-AC_GS_HAS_DEVICE(pngalpha,
- [GS_WARN="Your EPS inclusions will be cropped to the
- boundingbox, and rendered on an opaque background.
- Upgrade GhostScript to avoid this."
- AC_GS_HAS_DEVICE(png16m,
- [GS_WARN="Your EPS inclusions may not work.
- Upgrade/install GhostScript to avoid this."])])
-if test -n "$GS_WARN"; then
- AC_MSG_WARN([$GS_WARN])
-fi
ac_cv_lib_t1_T1_InitLib=yes
PSFONTS_O=""
@@ -182,7 +174,7 @@ fi
if test "$with_system_gd" = yes; then
OLD_LIBS=$LIBS
LIBS="$LDGD $LIBS"
- AC_CHECK_FUNCS([gdImageCreateTrueColor gdImagePngEx gdImageGif gdImageJpeg])
+ AC_CHECK_FUNCS([gdImageCreateTrueColor gdImageCreateFromJpeg gdImagePngEx gdImageCreateFromPngPtr gdImageGif FT_Library_Version])
LIBS=$OLD_LIBS
else
AC_DEFINE([HAVE_GDIMAGECREATETRUECOLOR])