summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-29 14:34:22 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-29 14:34:22 +0000
commit6be9f4dc7c015da2a94183970394935fd6ae72a2 (patch)
treee0e54cc331861f34533d6a240400f9cef789a287 /Build/source/texk/dvipng/Makefile.am
parent5d10ffc76a7d39e7523819add5a8cd46542b672f (diff)
fix Cygwin and Solaris build problems
git-svn-id: svn://tug.org/texlive/trunk@12856 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvipng/Makefile.am')
-rw-r--r--Build/source/texk/dvipng/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Build/source/texk/dvipng/Makefile.am b/Build/source/texk/dvipng/Makefile.am
index ea8b86f8fba..71a72ba252a 100644
--- a/Build/source/texk/dvipng/Makefile.am
+++ b/Build/source/texk/dvipng/Makefile.am
@@ -111,13 +111,18 @@ dist_noinst_SCRIPTS = texi2pod.pl
if have_gif
install-exec-hook:
- cd $(DESTDIR)/$(bindir) && rm -f dvigif && $(LN_S) dvipng dvigif
+ cd $(DESTDIR)$(bindir) && \
+ rm -f dvigif$(EXEEXT) && \
+ $(LN_S) dvipng$(EXEEXT) dvigif$(EXEEXT)
install-data-hook:
- cd $(DESTDIR)/$(man1dir) && rm -f dvigif.1 && $(LN_S) dvipng.1 dvigif.1
+ cd $(DESTDIR)$(man1dir) && \
+ rm -f dvigif.1 && \
+ $(LN_S) dvipng.1 dvigif.1
uninstall-hook:
- rm -f $(DESTDIR)/$(bindir)/dvigif $(DESTDIR)/$(man1dir)/dvigif.1
+ rm -f $(DESTDIR)$(bindir)/dvigif$(EXEEXT)
+ rm -f $(DESTDIR)$(man1dir)/dvigif.1
endif have_gif