summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:29:43 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:29:43 +0000
commit5fc8d99062f93c1d823ef44569549781d4a8e36b (patch)
tree9f47b0e74eb2ea982c8a888cab596eac38b2fc1b /Build/source/texk/dvipng/Makefile.am
parentf61bbe1e960052731889ff87ac1885f85b786f51 (diff)
towards TL2010: texk/dvipng
git-svn-id: svn://tug.org/texlive/trunk@15970 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvipng/Makefile.am')
-rw-r--r--Build/source/texk/dvipng/Makefile.am134
1 files changed, 57 insertions, 77 deletions
diff --git a/Build/source/texk/dvipng/Makefile.am b/Build/source/texk/dvipng/Makefile.am
index 7f6af504800..433264f432e 100644
--- a/Build/source/texk/dvipng/Makefile.am
+++ b/Build/source/texk/dvipng/Makefile.am
@@ -1,34 +1,34 @@
+## Makefile.am for the TeX Live subdirectory texk/dvipng/
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
##
#************************************************************************
#
-# Part of the dvipng distribution
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as
-# published by the Free Software Foundation, either version 3 of the
-# License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program. If not, see
-# <http://www.gnu.org/licenses/>.
-#
+# Adapted for TeX Live from dvipng-1.12/Makefile.in
# Copyright (C) 2002-2008 Jan-Åke Larsson
#
#************************************************************************
-#
-# Adapted for TeX Live by Peter Breitenlohner <peb@mppmu.mpg.de>
-# All settings here are our fault, don't blame the dvipng maintainer for it.
-#
-#************************************************************************
##
ACLOCAL_AMFLAGS = -I ../../m4 -I m4
-INCLUDES = $(KPATHSEA_INCLUDES) $(FREETYPE2_INCLUDES) $(GD_INCLUDES)
+## We want to re-distribute the whole original dvipng source tree.
+##
+## With current automake (1.10.2) 'make distcheck' fails when
+## DISTFILES contains a directory and files in that directory.
+## Thus nodist_* for all files in $(DVIPNG_TREE).
+EXTRA_DIST = $(DVIPNG_TREE)
+
+## Patches applied to the original source tree
+##
+EXTRA_DIST += $(DVIPNG_TREE)-PATCHES
+
+# in case of an SVN repository
+dist-hook:
+ rm -rf `find $(distdir) -name .svn`
+
+INCLUDES = -I$(top_srcdir)/$(DVIPNG_TREE)
+INCLUDES += $(KPATHSEA_INCLUDES) $(FREETYPE2_INCLUDES) $(GD_INCLUDES)
INCLUDES += $(T1LIB_INCLUDES) $(LIBPNG_INCLUDES) $(ZLIB_INCLUDES)
AM_CFLAGS = $(WARNING_CFLAGS)
@@ -38,43 +38,53 @@ TEXI2HTML = texi2html
# In order that `make distcheck' succeeds, we must not attempt to rebuild
# dvipng.info if dvipng.help has not changed, Thus we delegate rebuilding
-# dvipng.help and dvipng.info, if necessary, to subdirectories.
+# dvipng.help and dvipng.info, if necessary, to subdirectories.
SUBDIRS = . help doc
-## #################################### The program
-##
bin_PROGRAMS = dvipng
-dvipng_SOURCES = \
- color.c \
- commands.h \
- draw.c \
- dvi.c \
- dvipng.c \
- dvipng.h \
- font.c \
- misc.c \
- papersiz.c \
- pk.c \
- ppagelist.c \
- set.c \
- special.c \
- vf.c
+nodist_dvipng_SOURCES = \
+ $(DVIPNG_TREE)/color.c \
+ $(DVIPNG_TREE)/draw.c \
+ $(DVIPNG_TREE)/dvi.c \
+ $(DVIPNG_TREE)/dvipng.c \
+ $(DVIPNG_TREE)/font.c \
+ $(DVIPNG_TREE)/misc.c \
+ $(DVIPNG_TREE)/papersiz.c \
+ $(DVIPNG_TREE)/pk.c \
+ $(DVIPNG_TREE)/ppagelist.c \
+ $(DVIPNG_TREE)/set.c \
+ $(DVIPNG_TREE)/special.c \
+ $(DVIPNG_TREE)/vf.c
if have_t1
-dvipng_SOURCES += t1.c
+nodist_dvipng_SOURCES += \
+ $(DVIPNG_TREE)/t1.c
endif have_t1
if have_ft2
-dvipng_SOURCES += ft.c sfd.c
+nodist_dvipng_SOURCES += \
+ $(DVIPNG_TREE)/ft.c \
+ $(DVIPNG_TREE)/sfd.c
endif have_ft2
if have_ft2_or_t1
-dvipng_SOURCES += enc.c fontmap.c tfm.c
+nodist_dvipng_SOURCES += \
+ $(DVIPNG_TREE)/enc.c \
+ $(DVIPNG_TREE)/fontmap.c \
+ $(DVIPNG_TREE)/tfm.c
endif have_ft2_or_t1
-dvipng_DEPENDENCIES = $(KPATHSEA_DEPEND) $(FREETYPE2_DEPEND) $(GD_DEPEND)
-dvipng_DEPENDENCIES += $(T1LIB_DEPEND) $(LIBPNG_DEPEND) $(ZLIB_DEPEND)
+dvipng_dependencies = $(KPATHSEA_DEPEND) $(ZLIB_DEPEND) $(LIBPNG_DEPEND)
+dvipng_dependencies += $(T1LIB_DEPEND) $(FREETYPE2_DEPEND) $(GD_DEPEND)
+
+$(dvipng_OBJECTS): config.force
+
+config.force: $(dvipng_dependencies)
+ echo timestamp >config.force
+ $(SHELL) ./config.status --recheck
+
+DISTCLEANFILES = config.force
LDADD = $(KPATHSEA_LIBS) $(FREETYPE2_LIBS) $(GD_LIBS)
LDADD += $(T1LIB_LIBS) $(LIBPNG_LIBS) $(ZLIB_LIBS)
@@ -101,40 +111,10 @@ uninstall-hook:
rm -f $(DESTDIR)$(bindir)/dvigif$(EXEEXT)
endif have_gif
-## #################################### The test
-##
-test: test_dvipng.dvi dvipng$(EXEEXT)
- ./dvipng -T tight -strict test_dvipng
- echo View the result e.g. with xv test_dvipng\*.png
-
-test_dvipng.dvi: test_dvipng.tex
- latex $(srcdir)/test_dvipng.tex
-
TESTS = dvipng.test
+TESTS_ENVIRONMENT = DVIPNG_TREE='$(DVIPNG_TREE)'
-EXTRA_DIST = dvipng.test test_dvipng.tex
+EXTRA_DIST += dvipng.test
CLEANFILES = missfont.log test_dvipng.aux test_dvipng.dvi test_dvipng.log test_dvipng*.png
-## #################################### Maintainer targets
-##
-## Make sure INSTALL and README exist
-##
-EXTRA_DIST += ChangeLog.0 INSTALL README RELEASE
-
-## Not used
-##
-EXTRA_DIST += miktex.h miktex.mak
-
-## #################################### Build as part of the TeX Live tree
-##
-EXTRA_DIST += ChangeLog.TL
-
-## Patches applied to the dvipng-1.12 distribution
-##
-EXTRA_DIST += dvipng-1.12-patches
-
-## Original files from the dvipng distribution
-##
-EXTRA_DIST += Makefile.in.orig aclocal.m4.orig configure.ac.orig
-