summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-05-31 09:47:04 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-05-31 09:47:04 +0000
commit15cca88e2666b7aae4e54112a21cb5c9bc312069 (patch)
tree8b31517b2e92f03da2b949831029cd9439ce7cef /Build/source/texk/dvipng/Makefile.am
parent18662309a8be07470a0bc6294a1fddf5ffcb8d72 (diff)
Use the Makefile fragment `bin_links.am' to create symlinks within $(bindir)
For cygwin always create links `foo->bar.exe' and not `foo.exe->bar.exe' git-svn-id: svn://tug.org/texlive/trunk@22701 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvipng/Makefile.am')
-rw-r--r--Build/source/texk/dvipng/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Build/source/texk/dvipng/Makefile.am b/Build/source/texk/dvipng/Makefile.am
index 30e3a63e91d..e40ab1e6dab 100644
--- a/Build/source/texk/dvipng/Makefile.am
+++ b/Build/source/texk/dvipng/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for the TeX Live subdirectory texk/dvipng/
##
-## Copyright (C) 2009 - 2011 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2011 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
#************************************************************************
@@ -109,16 +109,16 @@ dvigif_LDADD =
## Rebuild libz
@ZLIB_RULE@
+include $(srcdir)/../am/bin_links.am
+
+bin_links = dvipng$(EXEEXT):dvigif
+
if have_gif
if WIN32
bin_PROGRAMS += dvigif
else !WIN32
-install-exec-hook:
- cd $(DESTDIR)$(bindir) && \
- rm -f dvigif$(EXEEXT) && \
- $(LN_S) dvipng$(EXEEXT) dvigif$(EXEEXT)
-uninstall-hook:
- rm -f $(DESTDIR)$(bindir)/dvigif$(EXEEXT)
+install-exec-hook: install-bin-links
+uninstall-hook: uninstall-bin-links
endif !WIN32
endif have_gif