summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipdfmx/configure.in
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2008-01-22 17:07:16 +0000
committerKarl Berry <karl@freefriends.org>2008-01-22 17:07:16 +0000
commitbc5394ac9b3f6b60b3fe464c233e957fcbb70108 (patch)
treec81e99337a1cd440de5c85861f4b5d1c7823d04d /Build/source/texk/dvipdfmx/configure.in
parent69ea3aeb335ff3585568f2051b7fb09871890fef (diff)
regenerate with autoconf 2.61 and automake 1.10.1
git-svn-id: svn://tug.org/texlive/trunk@6370 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/dvipdfmx/configure.in')
-rw-r--r--Build/source/texk/dvipdfmx/configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/Build/source/texk/dvipdfmx/configure.in b/Build/source/texk/dvipdfmx/configure.in
index 038fe3d1635..eab9d3951a1 100644
--- a/Build/source/texk/dvipdfmx/configure.in
+++ b/Build/source/texk/dvipdfmx/configure.in
@@ -9,14 +9,19 @@ AM_MAINTAINER_MODE
AC_DEFUN([AC_EXT_TIMEZONE],
[AC_MSG_CHECKING([whether time.h defines timezone as an external variable])
AC_TRY_LINK([#include <time.h>], [ -timezone; ],
- [AC_MSG_RESULT(yes); AC_DEFINE(HAVE_TIMEZONE)], [AC_MSG_RESULT(no)])])
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_TIMEZONE], [], [external timezone variable])],
+ [AC_MSG_RESULT(no)])])
AC_DEFUN([AC_TZ_HAS_TM_GMTOFF],
[AC_MSG_CHECKING([whether struct tz has tm_gmtoff as a member])
AC_TRY_COMPILE([#include <time.h>], [struct tm *tp; tp->tm_gmtoff],
- [AC_MSG_RESULT(yes); AC_DEFINE(HAVE_TM_GMTOFF)], [AC_MSG_RESULT(no)])])
+ [AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_TM_GMTOFF], [], [struct tz has tm_gmtoff])],
+ [AC_MSG_RESULT(no)])])
dnl Checks for programs.
AC_PROG_CC
+AM_PROG_CC_C_O
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
@@ -108,7 +113,7 @@ AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
-dnl Check for additonal libraries.
+dnl Check for additional libraries.
if test "x$enable_tetex_build" = xyes; then
# Get these common libraries from the sources, too.
# Seems like it would be simpler to treat kpathsea this way too, but