summaryrefslogtreecommitdiff
path: root/Build/source/texk/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
commit0df6dd4d8aea6edc733de81fb7eec115ea59a36e (patch)
treee2f7056cb53c58c8ef5779450ac468091b2bd86d /Build/source/texk/configure.ac
parent3675a91dd83af3eaa1c1a12e91af1e6c86f710f8 (diff)
build system: additional Makefile fragments
better handling of dependencies for highly parallel make git-svn-id: svn://tug.org/texlive/trunk@31127 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/configure.ac')
-rw-r--r--Build/source/texk/configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/Build/source/texk/configure.ac b/Build/source/texk/configure.ac
index 450bd9dbb11..58ccbac524d 100644
--- a/Build/source/texk/configure.ac
+++ b/Build/source/texk/configure.ac
@@ -21,22 +21,22 @@ KPSE_BASIC([texk])
AC_PROG_MKDIR_P
AC_MSG_CHECKING([for TeXk programs to build])
-SUBTEXK=
-DIST_SUBTEXK=
+MAKE_SUBDIRS=
+CONF_SUBDIRS=
KPSE_FOR_PKGS([texk], [
if test -x $srcdir/Kpse_Pkg/configure; then
- test "x$enable_[]Kpse_pkg" = xno || SUBTEXK="$SUBTEXK Kpse_Pkg"
+ test "x$enable_[]Kpse_pkg" = xno || MAKE_SUBDIRS="$MAKE_SUBDIRS Kpse_Pkg"
dnl Cause 'make dist' to recurse into all subtexk dirs
- DIST_SUBTEXK="$DIST_SUBTEXK Kpse_Pkg"
+ CONF_SUBDIRS="$CONF_SUBDIRS Kpse_Pkg"
dnl Cause 'configure -hr' and 'autoreconf' to recurse into all subtexk dirs
if false; then
AC_CONFIG_SUBDIRS(Kpse_Pkg)
fi
fi
])
-AC_SUBST([SUBTEXK])
-AC_SUBST([DIST_SUBTEXK])
-AC_MSG_RESULT([$SUBTEXK])
+AC_SUBST([MAKE_SUBDIRS])
+AC_SUBST([CONF_SUBDIRS])
+AC_MSG_RESULT([$MAKE_SUBDIRS])
AC_CONFIG_FILES([Makefile])