summaryrefslogtreecommitdiff
path: root/Build/source/texk/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-05 14:23:19 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-05 14:23:19 +0000
commitc1c0af52552e4b0c8a24acb36de9ca4705468da5 (patch)
treee95a66f73456ae82fa64d00462b7aae5afd5ff59 /Build/source/texk/Makefile.am
parent0948a06427b54c551d55aecf303d9406eb24d492 (diff)
better handling of make target triptrap
git-svn-id: svn://tug.org/texlive/trunk@17331 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/Makefile.am')
-rw-r--r--Build/source/texk/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Build/source/texk/Makefile.am b/Build/source/texk/Makefile.am
index f140c5f355f..bdc1e314966 100644
--- a/Build/source/texk/Makefile.am
+++ b/Build/source/texk/Makefile.am
@@ -61,3 +61,9 @@ subtexk: $(CONFIG_AUX)
# Common infrastructure for tests
EXTRA_DIST = tests/common-test.pl
+# Special target to run TRIP and TRAP tests and create diffs.
+.PHONY: triptrap
+triptrap: web2c/Makefile
+ cd web2c && $(MAKE) $(AM_MAKEFLAGS) $@
+web2c/Makefile:
+ $(MAKE) $(AM_MAKEFLAGS) DIST_SUBTEXK=web2c subtexk