summaryrefslogtreecommitdiff
path: root/Build/source/texk/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/texk/Makefile.am
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/Makefile.am')
-rw-r--r--Build/source/texk/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Build/source/texk/Makefile.am b/Build/source/texk/Makefile.am
new file mode 100644
index 00000000000..62ac31c687f
--- /dev/null
+++ b/Build/source/texk/Makefile.am
@@ -0,0 +1,29 @@
+## Makefile.am for the TeX Live subdirectory texk/
+##
+## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
+## Copyright 2016 Karl Berry <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+## Ensure aclocal.m4 is up to date
+ACLOCAL = @ACLOCAL@ --force
+
+SUBDIRS = . $(MAKE_SUBDIRS)
+DIST_SUBDIRS = $(CONF_SUBDIRS)
+
+# Files not to be distributed
+include $(srcdir)/../am/dist_hook.am
+
+## Configure and build subdirs.
+##
+recurse_this = texk/
+recurse_top = ../
+
+include $(srcdir)/../am/recurse.am
+
+# Common infrastructure for tests
+EXTRA_DIST = tests
+
+# Special target to run TRIP and TRAP tests and create diffs.
+.PHONY: triptrap
+triptrap:
+ cd web2c && $(MAKE) $(AM_MAKEFLAGS) $@