summaryrefslogtreecommitdiff
path: root/Build/source/texk/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:32:41 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-10 10:32:41 +0000
commit558303c70cdfd3bc2465cb99c2f8d81a64efcf31 (patch)
treeb308833d445fde6a5ad48558fe4eff1b86ab7ff7 /Build/source/texk/Makefile.am
parent81f0eba86eca049a6da0619b12d767e51aea3efb (diff)
towards TL2010: texk/ misc
git-svn-id: svn://tug.org/texlive/trunk@15976 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/Makefile.am')
-rw-r--r--Build/source/texk/Makefile.am25
1 files changed, 10 insertions, 15 deletions
diff --git a/Build/source/texk/Makefile.am b/Build/source/texk/Makefile.am
index f5f20ba7c95..ce062dd3659 100644
--- a/Build/source/texk/Makefile.am
+++ b/Build/source/texk/Makefile.am
@@ -7,17 +7,14 @@
##
ACLOCAL_AMFLAGS = -I ../m4 --force
-SUBDIRS = dummy . $(SUBTEXK)
-DIST_SUBDIRS = dummy $(DIST_SUBTEXK)
+SUBDIRS = . $(SUBTEXK)
+DIST_SUBDIRS = $(DIST_SUBTEXK)
# just in case a subdirectory has added directories
dist-hook:
rm -rf `find $(distdir) -name .svn`
-SUBTEXK_AUX = subtexkdir-configure subtexkdir-conf.args
-noinst_DATA = $(SUBTEXK_AUX)
-
-DISTCLEANFILES = $(noinst_DATA)
+CONFIG_AUX = ../subsubdir-conf.cmd
all-local: subtexk
@@ -29,7 +26,7 @@ all-local: subtexk
#
# Sequentially configure and optionally build all texk subdirs;
# code inspired by automake's way to handle recursive targets.
-subtexk: $(noinst_DATA)
+subtexk: $(CONFIG_AUX)
@failcom='exit 1'; \
for f in x $$MAKEFLAGS; do \
case $$f in \
@@ -40,14 +37,16 @@ subtexk: $(noinst_DATA)
list='$(DIST_SUBTEXK)'; for subtexk in $$list; do \
if test ! -f $$subtexk/Makefile; then \
test -d $$subtexk || $(MKDIR_P) $$subtexk; \
- cmd=`cat $(SUBTEXK_AUX) | sed "s,SUBTEXKDIR,$$subtexk,g"`; \
+ cmd=`cat $(CONFIG_AUX) | sed "s,auxdir/auxsub,texk/$$subtexk,g"`; \
case " $(SUBTEXK) " in \
*" $$subtexk "*) skip=;; \
*) skip=' --disable-build';; \
esac; \
(cd $$subtexk && echo "=== configuring in $$subtexk (`pwd`)" && \
echo "make: running $(SHELL) $$cmd$$skip" && \
- eval $(SHELL) $$cmd$$skip) && \
+ CONFIG_SHELL=$(SHELL) && export CONFIG_SHELL && \
+ eval $(SHELL) $$cmd$$skip || \
+ { echo "=== configuring in $$subtexk failed"; exit 1; }) && \
if test "x$$skip" = x; then \
echo "Making all in $$subtexk" && \
(cd $$subtexk && $(MAKE) $(AM_MAKEFLAGS) all); \
@@ -55,11 +54,7 @@ subtexk: $(noinst_DATA)
fi; \
done; test -z "$$fail"
-subtexkdir-configure:
- @echo "make in ./dummy failed to create the file $@"
- exit 1
-
-subtexkdir-conf.args:
- @echo "configure in ./dummy failed to create the file $@"
+../subsubdir-conf.cmd:
+ @echo "configure in ../auxdir/auxsub failed to create the file $@"
exit 1