summaryrefslogtreecommitdiff
path: root/Build/source/libs/zziplib/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2017-03-27 18:00:45 +0000
committerKarl Berry <karl@freefriends.org>2017-03-27 18:00:45 +0000
commitf6e2e4efbdd44ba2ce51fc1555361c23ec6c8beb (patch)
tree9997ce03ee8a6032c671c664ff04abc7e89e5729 /Build/source/libs/zziplib/Makefile.am
parentd87f8cf45a06f7b5db4d26d44843a947ab47f55f (diff)
Makefile.am (AM_TESTS_ENVIRONMENT): use instead of TESTS_ENVIRONMENT, per
https://www.gnu.org/software/automake/manual/html_node/Scripts_002dbased-Testsuites.html Means explicitly exporting all variables, unfortunately. (EXTRA_DIST): correct Tlpatches typo to TLpatches. git-svn-id: svn://tug.org/texlive/trunk@43617 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/zziplib/Makefile.am')
-rw-r--r--Build/source/libs/zziplib/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/Build/source/libs/zziplib/Makefile.am b/Build/source/libs/zziplib/Makefile.am
index 45f663d55db..e655816c109 100644
--- a/Build/source/libs/zziplib/Makefile.am
+++ b/Build/source/libs/zziplib/Makefile.am
@@ -7,14 +7,12 @@
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
## with or without modifications, as long as this notice is preserved.
-##
+
## We want to re-distribute the whole zziplib source tree.
-##
EXTRA_DIST = $(ZZIPLIB_TREE)
## Changes applied to the original source tree
-##
-EXTRA_DIST += Tlpatches
+EXTRA_DIST += TLpatches
# Files not to be distributed
include $(srcdir)/../../am/dist_hook.am
@@ -43,7 +41,7 @@ $(libzzip_a_OBJECTS): config.force
DISTCLEANFILES = include/_msvc.in _configs.sed
-TESTS_ENVIRONMENT = ZZIPLIB_TREE=$(ZZIPLIB_TREE)
+AM_TESTS_ENVIRONMENT = ZZIPLIB_TREE=$(ZZIPLIB_TREE); export ZZIPLIB_TREE;
if build
TESTS = zziplib.test
check_PROGRAMS = unzzip
@@ -71,4 +69,3 @@ rebuild_target = all
CLEANFILES =
include $(srcdir)/../../am/rebuild.am
-