summaryrefslogtreecommitdiff
path: root/Build/source/libs/zlib/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-21 09:44:45 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-21 09:44:45 +0000
commitb77e78eaf3652b80e78ae80f770bd3bdf721363d (patch)
treed3c67296e30534c63d02c5bb5e5790b1d9150cd0 /Build/source/libs/zlib/Makefile.am
parentad04e2284cbf8d1a4b268636c7451f89d29c4d0a (diff)
new build system: mode texk/xdvik and general update
git-svn-id: svn://tug.org/texlive/trunk@12771 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/zlib/Makefile.am')
-rw-r--r--Build/source/libs/zlib/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/Build/source/libs/zlib/Makefile.am b/Build/source/libs/zlib/Makefile.am
index 5d126bb4135..6f188a23e3d 100644
--- a/Build/source/libs/zlib/Makefile.am
+++ b/Build/source/libs/zlib/Makefile.am
@@ -23,17 +23,9 @@ INCLUDES = -I$(top_srcdir)/$(ZLIB_TREE)
AM_CPPFLAGS = $(ZLIB_DEFINES)
if build
-
noinst_LIBRARIES = libz.a
-
-BUILT_SOURCES = zconf.h
-
-check_PROGRAMS = example minigzip
-dist_check_SCRIPTS = zlib.test
-
-TESTS = zlib.test
-
endif build
+EXTRA_LIBRARIES = libz.a
nodist_libz_a_SOURCES = \
$(ZLIB_TREE)/adler32.c \
@@ -57,6 +49,14 @@ nodist_libz_a_SOURCES = \
$(ZLIB_TREE)/zutil.h \
$(ZLIB_TREE)/zutil.c
+$(libz_a_OBJECTS): zconf.h
+
+if build
+check_PROGRAMS = example minigzip
+dist_check_SCRIPTS = zlib.test
+TESTS = zlib.test
+endif build
+
LDADD = libz.a
nodist_example_SOURCES = $(ZLIB_TREE)/example.c