summaryrefslogtreecommitdiff
path: root/Build/source/libs/xpdf/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-08-22 13:45:08 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-08-22 13:45:08 +0000
commitd28101658050e6245fc1ea5f67bd1b48f8ff760d (patch)
treea45de21c28a8e9904bfe6b4afe4b5614e7b12a3e /Build/source/libs/xpdf/Makefile.am
parentca71f577a6ad4dbd109007f0f61b0d5a2029b8cc (diff)
xpdf 3.03
git-svn-id: svn://tug.org/texlive/trunk@23646 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/xpdf/Makefile.am')
-rw-r--r--Build/source/libs/xpdf/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Build/source/libs/xpdf/Makefile.am b/Build/source/libs/xpdf/Makefile.am
index 998eec25728..103ec6e05f9 100644
--- a/Build/source/libs/xpdf/Makefile.am
+++ b/Build/source/libs/xpdf/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to build xpdf for TeX Live.
##
-## Copyright (C) 2009 - 2011 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2011 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -31,6 +31,7 @@ rebuild: all
EXTRA_DIST = $(XPDF_TREE)
## Official patches as obtained from ftp://ftp.foolabs.com/pub/xpdf
+## (if any)
##
EXTRA_DIST += $(XPDF_TREE)-foolabs
@@ -43,13 +44,14 @@ dist-hook:
rm -rf `find $(distdir) -name .svn`
rm -f $(distdir)/$(XPDF_TREE)/install-sh
-SUBDIRS = goo fofi xpdf
+SUBDIRS = goo fofi splash xpdf
GOO_SRC = $(top_srcdir)/$(XPDF_TREE)/goo
FOFI_SRC = $(top_srcdir)/$(XPDF_TREE)/fofi
+SPLAHS_SRC = $(top_srcdir)/$(XPDF_TREE)/splash
XPDF_SRC = $(top_srcdir)/$(XPDF_TREE)/xpdf
-INCLUDES = -Igoo -Ifofi -Ixpdf -I$(GOO_SRC) -I$(FOFI_SRC) -I$(XPDF_SRC)
+INCLUDES = -Igoo -Ifofi -Isplash -Ixpdf -I$(GOO_SRC) -I$(FOFI_SRC) -I$(SPLAHS_SRC) -I$(XPDF_SRC)
AM_CPPFLAGS = -DPDF_PARSER_ONLY
AM_CFLAGS = $(WARNING_CFLAGS)
AM_CXXFLAGS = $(NO_WARN_CXXFLAGS)
@@ -73,6 +75,7 @@ goo_libGoo_a_sources = \
fofi_libfofi_a_sources = \
$(FOFI_SRC)/FoFiBase.cc \
$(FOFI_SRC)/FoFiEncodings.cc \
+ $(FOFI_SRC)/FoFiIdentifier.cc \
$(FOFI_SRC)/FoFiTrueType.cc \
$(FOFI_SRC)/FoFiType1.cc \
$(FOFI_SRC)/FoFiType1C.cc
@@ -99,6 +102,7 @@ xpdf_libxpdf_a_sources = \
$(XPDF_SRC)/Link.cc \
$(XPDF_SRC)/NameToCharCode.cc \
$(XPDF_SRC)/Object.cc \
+ $(XPDF_SRC)/OptionalContent.cc \
$(XPDF_SRC)/Outline.cc \
$(XPDF_SRC)/OutputDev.cc \
$(XPDF_SRC)/PDFDoc.cc \