summaryrefslogtreecommitdiff
path: root/Build/source/libs/teckit/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-01-30 09:41:34 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-01-30 09:41:34 +0000
commit0428e986f06209f75419776b630d34e93080d57a (patch)
treec9c9d2568452d95542b1d6461187e7548be116b7 /Build/source/libs/teckit/Makefile.am
parent27c9c2d0e7b7b11e85e6fbffb7ee0e0742d4daef (diff)
build system: Allow subdir-objects as required for Automake 1.14
git-svn-id: svn://tug.org/texlive/trunk@28989 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/teckit/Makefile.am')
-rw-r--r--Build/source/libs/teckit/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Build/source/libs/teckit/Makefile.am b/Build/source/libs/teckit/Makefile.am
index 36b750df6ac..722d79878fa 100644
--- a/Build/source/libs/teckit/Makefile.am
+++ b/Build/source/libs/teckit/Makefile.am
@@ -1,6 +1,6 @@
## Makefile.am for the TeX Live subdirectory libs/teckit/
##
-## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
ACLOCAL_AMFLAGS = -I ../../m4
@@ -22,7 +22,7 @@ EXTRA_DIST += $(TECKIT_TREE)-PATCHES
# in case of an SVN repository
dist-hook:
- rm -rf `find $(distdir) -name .svn`
+ rm -rf `find $(distdir) -name .svn -o -name .deps -o -name .dirstamp -o -name '*.$(OBJEXT)'`
SUBDIRS = include/teckit
@@ -38,7 +38,7 @@ noinst_LIBRARIES = libTECkit_Compiler.a libTECkit.a
# teckit_compile
#
nodist_teckit_compile_SOURCES = \
- $(TECKIT_TREE)/source/Sample-tools/TECkit_Compile.cpp
+ @TECKIT_TREE@/source/Sample-tools/TECkit_Compile.cpp
teckit_compile_LDADD = libTECkit_Compiler.a $(ZLIB_LIBS)
@@ -47,11 +47,11 @@ $(teckit_compile_OBJECTS): libTECkit_Compiler.a
# libTECkit_Compiler.a and libTECkit.a
#
nodist_libTECkit_Compiler_a_SOURCES = \
- $(TECKIT_TREE)/source/Compiler.cpp \
- $(TECKIT_TREE)/source/UnicodeNames.cpp
+ @TECKIT_TREE@/source/Compiler.cpp \
+ @TECKIT_TREE@/source/UnicodeNames.cpp
nodist_libTECkit_a_SOURCES = \
- $(TECKIT_TREE)/source/Engine.cpp
+ @TECKIT_TREE@/source/Engine.cpp
$(libTECkit_Compiler_a_OBJECTS) $(libTECkit_a_OBJECTS): config.force