summaryrefslogtreecommitdiff
path: root/Build/source/libs/pplib/include/Makefile.am
diff options
context:
space:
mode:
authorLuigi Scarso <luigi.scarso@gmail.com>2020-04-21 18:43:36 +0000
committerLuigi Scarso <luigi.scarso@gmail.com>2020-04-21 18:43:36 +0000
commit7c0b908f1a6e1489834fbdb0789766eed8a37b49 (patch)
treecb55d631b861bfcf95fe853713af6f760227ba0f /Build/source/libs/pplib/include/Makefile.am
parente783b071ded7eef421d0333416b47142bc5542cb (diff)
pplib under libs -- WORK IN PROGRSS grep '?' out
git-svn-id: svn://tug.org/texlive/trunk@54824 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/pplib/include/Makefile.am')
-rw-r--r--Build/source/libs/pplib/include/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Build/source/libs/pplib/include/Makefile.am b/Build/source/libs/pplib/include/Makefile.am
new file mode 100644
index 00000000000..fc3e6b694f2
--- /dev/null
+++ b/Build/source/libs/pplib/include/Makefile.am
@@ -0,0 +1,43 @@
+## Proxy Makefile.am to install pplib headers for TeX Live.
+##
+## Copyright (C) 2013 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+PPLIB_SRC = $(top_srcdir)/$(PPLIB_TREE)/src
+
+hdr_links = \
+ $(PPLIB_SRC)/ppapi.h \
+ $(PPLIB_SRC)/pparray.h \
+ $(PPLIB_SRC)/ppconf.h \
+ $(PPLIB_SRC)/ppcrypt.h \
+ $(PPLIB_SRC)/ppdict.h \
+ $(PPLIB_SRC)/ppfilter.h \
+ $(PPLIB_SRC)/ppheap.h \
+ $(PPLIB_SRC)/pplib.h \
+ $(PPLIB_SRC)/ppload.h \
+ $(PPLIB_SRC)/ppstream.h \
+ $(PPLIB_SRC)/ppxref.h \
+ $(PPLIB_SRC)/util/utilbasexx.h \
+ $(PPLIB_SRC)/util/utilcrypt.h \
+ $(PPLIB_SRC)/util/utilcryptdef.h \
+ $(PPLIB_SRC)/util/utildecl.h \
+ $(PPLIB_SRC)/util/utilflate.h \
+ $(PPLIB_SRC)/util/utilfpred.h \
+ $(PPLIB_SRC)/util/utiliof.h \
+ $(PPLIB_SRC)/util/utillog.h \
+ $(PPLIB_SRC)/util/utillzw.h \
+ $(PPLIB_SRC)/util/utilmd5.h \
+ $(PPLIB_SRC)/util/utilmem.h \
+ $(PPLIB_SRC)/util/utilmemallc.h \
+ $(PPLIB_SRC)/util/utilmemallh.h \
+ $(PPLIB_SRC)/util/utilmemheap.h \
+ $(PPLIB_SRC)/util/utilmemheapiof.h \
+ $(PPLIB_SRC)/util/utilmeminfo.h \
+ $(PPLIB_SRC)/util/utilnumber.h \
+ $(PPLIB_SRC)/util/utilplat.h \
+ $(PPLIB_SRC)/util/utilsha.h
+
+include $(top_srcdir)/../../am/hdr_links.am