summaryrefslogtreecommitdiff
path: root/Build/source/libs/poppler/poppler-0.18.4/goo/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-02-23 10:27:56 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-02-23 10:27:56 +0000
commit9fbfe507d0f9d90df2880e61eb4e5280206ae6b9 (patch)
tree889986f162ee830547e15a8b0d4c6e12613b0f03 /Build/source/libs/poppler/poppler-0.18.4/goo/Makefile.am
parent244a7062d4b2b6d10c769244d2c7e1f57de39018 (diff)
poppler 0.18.4
git-svn-id: svn://tug.org/texlive/trunk@25482 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/poppler/poppler-0.18.4/goo/Makefile.am')
-rw-r--r--Build/source/libs/poppler/poppler-0.18.4/goo/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/Build/source/libs/poppler/poppler-0.18.4/goo/Makefile.am b/Build/source/libs/poppler/poppler-0.18.4/goo/Makefile.am
new file mode 100644
index 00000000000..1921b1ea4ea
--- /dev/null
+++ b/Build/source/libs/poppler/poppler-0.18.4/goo/Makefile.am
@@ -0,0 +1,47 @@
+noinst_LTLIBRARIES = libgoo.la
+
+if ENABLE_XPDF_HEADERS
+
+poppler_goo_includedir = $(includedir)/poppler/goo
+poppler_goo_include_HEADERS = \
+ GooHash.h \
+ GooList.h \
+ GooTimer.h \
+ GooMutex.h \
+ GooString.h \
+ gtypes.h \
+ gmem.h \
+ gfile.h \
+ FixedPoint.h \
+ PNGWriter.h \
+ JpegWriter.h \
+ TiffWriter.h \
+ ImgWriter.h \
+ GooLikely.h \
+ gstrtod.h
+
+endif
+
+if BUILD_LIBPNG
+libpng_includes = $(LIBPNG_CFLAGS)
+endif
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ $(libpng_includes)
+
+libgoo_la_SOURCES = \
+ gfile.cc \
+ gmempp.cc \
+ GooHash.cc \
+ GooList.cc \
+ GooTimer.cc \
+ GooString.cc \
+ gmem.cc \
+ FixedPoint.cc \
+ PNGWriter.cc \
+ JpegWriter.cc \
+ TiffWriter.cc \
+ ImgWriter.cc \
+ gtypes_p.h \
+ gstrtod.cc