summaryrefslogtreecommitdiff
path: root/Build/source/libs/poppler/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-06-24 08:24:44 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-06-24 08:24:44 +0000
commit98bd36b19e0aee9d8ef2d560d4fc32ed2036251b (patch)
treedfb9f52097d0b95d2b8a5f2c1625bb5d5877388f /Build/source/libs/poppler/Makefile.am
parent611c8928492ae0b013c2d2d950980345ea5fe38d (diff)
poppler 0.23.2
git-svn-id: svn://tug.org/texlive/trunk@30882 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/poppler/Makefile.am')
-rw-r--r--Build/source/libs/poppler/Makefile.am23
1 files changed, 13 insertions, 10 deletions
diff --git a/Build/source/libs/poppler/Makefile.am b/Build/source/libs/poppler/Makefile.am
index e9ee231996c..db9615959b1 100644
--- a/Build/source/libs/poppler/Makefile.am
+++ b/Build/source/libs/poppler/Makefile.am
@@ -24,13 +24,13 @@ EXTRA_DIST += $(POPPLER_TREE)-PATCHES
dist-hook:
rm -rf `find $(distdir) -name .svn -o -name .deps -o -name .dirstamp -o -name '*.$(OBJEXT)'`
-SUBDIRS = goo fofi poppler
+SUBDIRS = . include
GOO_SRC = $(top_srcdir)/$(POPPLER_TREE)/goo
FOFI_SRC = $(top_srcdir)/$(POPPLER_TREE)/fofi
POPPLER_SRC = $(top_srcdir)/$(POPPLER_TREE)/poppler
-AM_CPPFLAGS = -Igoo -Ifofi -Ipoppler -I$(GOO_SRC) -I$(FOFI_SRC) -I$(POPPLER_SRC) $(ZLIB_INCLUDES)
+AM_CPPFLAGS = -I$(top_srcdir)/$(POPPLER_TREE) -I$(GOO_SRC) $(ZLIB_INCLUDES)
AM_CPPFLAGS += -DPOPPLER_DATADIR='"."'
AM_CFLAGS = $(WARNING_CFLAGS)
AM_CXXFLAGS = $(NO_WARN_CXXFLAGS)
@@ -43,16 +43,16 @@ nodist_libpoppler_a_SOURCES = \
$(poppler_libpoppler_a_sources)
goo_libGoo_a_sources = \
- @POPPLER_TREE@/goo/FixedPoint.cc \
@POPPLER_TREE@/goo/gfile.cc \
@POPPLER_TREE@/goo/gmem.cc \
@POPPLER_TREE@/goo/gmempp.cc \
+ @POPPLER_TREE@/goo/grandom.cc \
+ @POPPLER_TREE@/goo/gstrtod.cc \
+ @POPPLER_TREE@/goo/FixedPoint.cc \
@POPPLER_TREE@/goo/GooHash.cc \
@POPPLER_TREE@/goo/GooList.cc \
@POPPLER_TREE@/goo/GooString.cc \
- @POPPLER_TREE@/goo/GooTimer.cc \
- @POPPLER_TREE@/goo/grandom.cc \
- @POPPLER_TREE@/goo/gstrtod.cc
+ @POPPLER_TREE@/goo/GooTimer.cc
fofi_libfofi_a_sources = \
@POPPLER_TREE@/fofi/FoFiBase.cc \
@@ -89,8 +89,8 @@ poppler_libpoppler_a_sources = \
@POPPLER_TREE@/poppler/JArithmeticDecoder.cc \
@POPPLER_TREE@/poppler/JBIG2Stream.cc \
@POPPLER_TREE@/poppler/JPXStream.cc \
- @POPPLER_TREE@/poppler/Linearization.cc \
@POPPLER_TREE@/poppler/Lexer.cc \
+ @POPPLER_TREE@/poppler/Linearization.cc \
@POPPLER_TREE@/poppler/Link.cc \
@POPPLER_TREE@/poppler/Movie.cc \
@POPPLER_TREE@/poppler/NameToCharCode.cc \
@@ -100,6 +100,7 @@ poppler_libpoppler_a_sources = \
@POPPLER_TREE@/poppler/OutputDev.cc \
@POPPLER_TREE@/poppler/PDFDoc.cc \
@POPPLER_TREE@/poppler/PDFDocEncoding.cc \
+ @POPPLER_TREE@/poppler/PDFDocFactory.cc \
@POPPLER_TREE@/poppler/PSTokenizer.cc \
@POPPLER_TREE@/poppler/Page.cc \
@POPPLER_TREE@/poppler/PageLabelInfo.cc \
@@ -111,14 +112,16 @@ poppler_libpoppler_a_sources = \
@POPPLER_TREE@/poppler/Rendition.cc \
@POPPLER_TREE@/poppler/SecurityHandler.cc \
@POPPLER_TREE@/poppler/Sound.cc \
+ @POPPLER_TREE@/poppler/StdinCachedFile.cc \
+ @POPPLER_TREE@/poppler/StdinPDFDocBuilder.cc \
@POPPLER_TREE@/poppler/Stream.cc \
- @POPPLER_TREE@/poppler/strtok_r.cpp \
+ @POPPLER_TREE@/poppler/UTF.cc \
@POPPLER_TREE@/poppler/UnicodeMap.cc \
@POPPLER_TREE@/poppler/UnicodeTypeTable.cc \
- @POPPLER_TREE@/poppler/UTF.cc \
@POPPLER_TREE@/poppler/ViewerPreferences.cc \
@POPPLER_TREE@/poppler/XRef.cc \
- @POPPLER_TREE@/poppler/XpdfPluginAPI.cc
+ @POPPLER_TREE@/poppler/XpdfPluginAPI.cc \
+ @POPPLER_TREE@/poppler/strtok_r.cpp
$(libpoppler_a_OBJECTS): config.force