summaryrefslogtreecommitdiff
path: root/Build/source/libs/pixman/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-04-06 14:24:12 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-04-06 14:24:12 +0000
commit2816a1b1966838288488c105a962f0fbf6f90002 (patch)
tree7b6c4023973b494bd0c83b3a9cedbcf5afb05cb2 /Build/source/libs/pixman/configure.ac
parentb597d53618e8a066fb56ab21d2e0e04fc6cc809a (diff)
pixman: Build fix for systems without sqrtf(), e.g., Solaris 9
git-svn-id: svn://tug.org/texlive/trunk@29694 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/pixman/configure.ac')
-rw-r--r--Build/source/libs/pixman/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/Build/source/libs/pixman/configure.ac b/Build/source/libs/pixman/configure.ac
index ff045b6eef9..85ddbfb04ee 100644
--- a/Build/source/libs/pixman/configure.ac
+++ b/Build/source/libs/pixman/configure.ac
@@ -53,6 +53,12 @@ dnl add all these to config.h.in but do not define them in config.h
[Whether the tool chain supports __attribute__((constructor))])
fi
+AC_SEARCH_LIBS([sqrtf], [m])
+if "x$ac_cv_search_sqrtf" = xno; then
+ AC_DEFINE([sqrtf], [sqrt],
+ [Define to sqrt if you do not have the `sqrtf' function.])
+fi
+
dnl PIXMAN_LINK_WITH_ENV(env-setup, program, true-action, false-action)
dnl
dnl Compiles and links the given program in the environment setup by env-setup