summaryrefslogtreecommitdiff
path: root/Build/source/libs/luajit/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2019-03-26 22:20:41 +0000
committerKarl Berry <karl@freefriends.org>2019-03-26 22:20:41 +0000
commitfb1e0c5fe2145af58861c1d1a42b9c03d8d6a37f (patch)
treec597437af86955eb2b16cab0ae8c8c2aa0a7a805 /Build/source/libs/luajit/configure.ac
parent1bd89250219a1f2d07e579df52dce11bbcd7e994 (diff)
for openbsd, LIBLUAJIT_LDEXTRA='-lc++abi -lpthread'
git-svn-id: svn://tug.org/texlive/trunk@50609 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/luajit/configure.ac')
-rw-r--r--Build/source/libs/luajit/configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/Build/source/libs/luajit/configure.ac b/Build/source/libs/luajit/configure.ac
index f3e20d48159..04bd5613647 100644
--- a/Build/source/libs/luajit/configure.ac
+++ b/Build/source/libs/luajit/configure.ac
@@ -1,6 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2014, 2015 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright 2016-2019 Karl Berry <tex-live@tug.org>
+dnl Copyright 2014-2015 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
@@ -63,8 +64,15 @@ AC_SUBST([LUAJIT_CFLAGS])
AC_SUBST([LJHOST])
AC_SUBST([LJVM_MODE])
+dnl Extra switches
+dnl We support openbsd x86_64 and i386,
+dnl other platforms could require different switches.
+dnl
AS_CASE([$host_os:$host_cpu],
[*darwin*:x86_64], [LIBLUAJIT_LDEXTRA='-image_base 7fff04c4a000'])
+AS_CASE([$host_os:$host_cpu:$CC],
+ [*openbsd*:x86_64:clang* | *openbsd*:x86_64:cc], [LIBLUAJIT_LDEXTRA='-lc++abi -lpthread'],
+ [*openbsd*:i386:clang* | *openbsd*:i386:cc], [LIBLUAJIT_LDEXTRA='-lc++abi -lpthread'])
AC_SUBST([LIBLUAJIT_LDEXTRA])
AM_CONDITIONAL([build], [test "x$enable_build" != xno])