summaryrefslogtreecommitdiff
path: root/Build/source/libs/luajit/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-03-10 08:41:33 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-03-10 08:41:33 +0000
commit4f9258a5a6751c1ad14a1d28198bd9e1270ba98d (patch)
treeb6fb444d44d2506943190425d9ec92351212e33a /Build/source/libs/luajit/configure.ac
parentd5c1c39051c6ce87b25c42e170dc0216b80936bd (diff)
libs/luajit: Do not fail when not building the libray
git-svn-id: svn://tug.org/texlive/trunk@33140 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/luajit/configure.ac')
-rw-r--r--Build/source/libs/luajit/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/Build/source/libs/luajit/configure.ac b/Build/source/libs/luajit/configure.ac
index f8ecce6d473..38ba43f560e 100644
--- a/Build/source/libs/luajit/configure.ac
+++ b/Build/source/libs/luajit/configure.ac
@@ -28,6 +28,12 @@ AC_SEARCH_LIBS([dlopen], [dl])
KPSE_LUAJIT_DEFINES
KPSE_LARGEFILE([LUAJIT_DEFINES])
+AS_CASE([$host_os],
+ [cygwin* | mingw* | msys*], [LJHOST='Windows'],
+ [darwin*], [LJHOST='Darwin'],
+ [solaris* | sunos*], [LJHOST='SunOS'],
+ [linux*], [LJHOST='Linux'],
+ [LJHOST='Other'])
LJ_ARCH()
AS_CASE([$LJHOST],
[Windows], [LJVM_MODE=peobj
@@ -35,10 +41,20 @@ AS_CASE([$LJHOST],
[Darwin | iOS], [LJVM_MODE=machasm],
[LJVM_MODE=elfasm])
AM_CONDITIONAL([PEOBJ], [test "x$LJVM_MODE" = xpeobj])
+
+AC_SUBST([LJHOST])
AC_SUBST([LJVM_MODE])
AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+if test "x$enable_build" != xno || test -f config.force; then
+
+AS_IF([test "x$lj_cpp" != xok],
+ [AC_MSG_ERROR([Sorry, can not preprocess <lj_arch.h>])])
+
+echo timestamp >config.force
+fi
+
AC_SUBST([LUAJIT_TREE], [LuaJIT-]luajit_version)
dnl Not used but avoids putting a zillion useless -D's on the command line.