summaryrefslogtreecommitdiff
path: root/Build/source/libs/luajit/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-02-06 11:03:15 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-02-06 11:03:15 +0000
commit4169934ceb43a6b413b4280552bcd309333b469a (patch)
tree90b2dd58cf99f27746bbd73ee559d1129622e329 /Build/source/libs/luajit/configure.ac
parentacd760cd6f255a87dae356c716aa142d06dce1d6 (diff)
LuaJIT 2.0.2
git-svn-id: svn://tug.org/texlive/trunk@32877 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/luajit/configure.ac')
-rw-r--r--Build/source/libs/luajit/configure.ac47
1 files changed, 47 insertions, 0 deletions
diff --git a/Build/source/libs/luajit/configure.ac b/Build/source/libs/luajit/configure.ac
new file mode 100644
index 00000000000..299f12e9d69
--- /dev/null
+++ b/Build/source/libs/luajit/configure.ac
@@ -0,0 +1,47 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2014 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_include([version.ac])[] dnl define luajit_version
+AC_INIT([luajit for TeX Live], luajit_version, [luigi.scarso@gmail.com])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([LuaJIT-]luajit_version[/src/luajit.h])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+KPSE_BASIC([luajit])
+
+AC_CANONICAL_HOST
+
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_LN_S
+
+AC_SEARCH_LIBS([sqrt], [m])
+
+KPSE_COND_WIN32
+
+AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+
+AC_SUBST([LUAJIT_TREE], [LuaJIT-]luajit_version)
+
+AC_CONFIG_FILES([Makefile])
+
+AC_CONFIG_SUBDIRS([native])
+
+AS_IF([test "x$cross_compiling" = xyes],
+ [AC_SUBST([CROSS], [$host-])])
+
+dnl The subdirectory native must be configured for the build system.
+dnl When cross compiling, can not share the cache file with the subdirectory!
+AC_CONFIG_COMMANDS_POST([AS_IF([test "x$cross_compiling" = xyes],
+[cache_file=/dev/null
+ ac_configure_args="$ac_configure_args --host='$kpse_build_alias' \
+ CC='$BUILDCC' CPPFLAGS='$BUILDCPPFLAGS'\
+ CFLAGS='$BUILDCFLAGS' LDFLAGS='$BUILDLDFLAGS'"])])
+
+AC_OUTPUT