summaryrefslogtreecommitdiff
path: root/Build/source/libs/lua52/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2014-03-03 10:38:50 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2014-03-03 10:38:50 +0000
commitff09b3baf412d5e76069d928b3be7faf1f909a72 (patch)
treee497ea8ed4caa349ccd8ed1b399650d54f037026 /Build/source/libs/lua52/Makefile.am
parent8a4e73b3b2f4ffef7bf105234e9b023f30cf2816 (diff)
libs/lua52: New test checking error handling
libs/luajit: New test checking error handling git-svn-id: svn://tug.org/texlive/trunk@33086 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/lua52/Makefile.am')
-rw-r--r--Build/source/libs/lua52/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Build/source/libs/lua52/Makefile.am b/Build/source/libs/lua52/Makefile.am
index 014598e1522..e8ef2795699 100644
--- a/Build/source/libs/lua52/Makefile.am
+++ b/Build/source/libs/lua52/Makefile.am
@@ -63,21 +63,27 @@ nodist_liblua52_a_SOURCES = \
@LUA52_TREE@/src/lzio.c
if build
-check_PROGRAMS = luatest
-dist_check_SCRIPTS = lua52.test
-TESTS = lua52.test
+check_PROGRAMS = luatest luatry
+dist_check_SCRIPTS = lua52.test luaerror.test
+TESTS = lua52.test luaerror.test
endif build
luatest_SOURCES = luatest.c
luatest_CPPFLAGS = -Iinclude
+nodist_luatry_SOURCES = @LUA52_TREE@/src/lua.c
+
+luatry_CPPFLAGS = -Iinclude
+
LDADD = liblua52.a
+EXTRA_DIST += error.exp
+CLEANFILES = error.out
+
# Rebuild
rebuild_prereq =
rebuild_target = all
-CLEANFILES =
include $(srcdir)/../../am/rebuild.am