summaryrefslogtreecommitdiff
path: root/Build/source/libs/icu/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-20 18:13:48 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-04-20 18:13:48 +0000
commite5786f530f9555469c01435f86039b06aa53feba (patch)
treec868e8d32282422d7d445b729db95c3fcdafb6d0 /Build/source/libs/icu/Makefile.am
parentebaa1768b43c8606d923d2e861b5286b74207b3e (diff)
new build system: build icu libs and xetex plus misc updates
git-svn-id: svn://tug.org/texlive/trunk@12759 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/icu/Makefile.am')
-rw-r--r--Build/source/libs/icu/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/Build/source/libs/icu/Makefile.am b/Build/source/libs/icu/Makefile.am
new file mode 100644
index 00000000000..1798c7ba48d
--- /dev/null
+++ b/Build/source/libs/icu/Makefile.am
@@ -0,0 +1,53 @@
+## Proxy Makefile.am to build icu-xetex for TeX Live.
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+##
+## This file is free software; the copyright holder
+## gives unlimited permission to copy and/or distribute it,
+## with or without modifications, as long as this notice is preserved.
+##
+ACLOCAL_AMFLAGS = -I ../../m4
+
+SUBDIRS = dummy
+
+## We want to re-distribute the whole icu-xetex source tree.
+EXTRA_DIST = icu-xetex
+
+## in case of an SVN repository
+dist-hook:
+ rm -rf `find $(distdir)/icu-xetex -name .svn`
+
+ICUSUB_AUX = icusubdir-configure icusubdir-conf.args
+noinst_DATA = $(ICUSUB_AUX)
+
+DISTCLEANFILES = $(noinst_DATA)
+
+if build
+all-local: icubuild
+else !build
+all-local: icu-build/Makefile
+endif !build
+
+icu-build/Makefile: $(noinst_DATA)
+ $(mkdir_p) icu-build
+ @cmd=`cat $(ICUSUB_AUX)`; \
+ cmd="$$cmd --enable-static --disable-shared --disable-extras --disable-samples --disable-tests"; \
+ (cd icu-build && echo "=== configuring in icu-build (`pwd`)" && \
+ echo "make: running $(SHELL) $$cmd" && \
+ eval $(SHELL) $$cmd)
+
+.PHONY: icubuild
+icubuild: icu-build/Makefile
+ cd icu-build && $(MAKE) $(AM_MAKEFLAGS) all
+
+distclean-local:
+ rm -rf icu-build
+
+icusubdir-configure:
+ @echo "make in ./dummy failed to create the file $@"
+ exit 1
+
+icusubdir-conf.args:
+ @echo "configure in ./dummy failed to create the file $@"
+ exit 1
+