summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2016-02-19 14:02:02 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2016-02-19 14:02:02 +0000
commit1574815ed78c28a3881dd35100d988b0c5093868 (patch)
treeee5b59790bf80c1beb044942e04f464db6198f6b /Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
parent119ed5771f95060a3cd83c5c9b69f368d40ed69f (diff)
libs/harfbuzz: HarfBuzz 1.2.0
git-svn-id: svn://tug.org/texlive/trunk@39781 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/configure.ac')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/configure.ac29
1 files changed, 28 insertions, 1 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
index 764211553dc..d4c8f953807 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.64])
AC_INIT([HarfBuzz],
- [1.1.3],
+ [1.2.0],
[http://bugs.freedesktop.org/enter_bug.cgi?product=harfbuzz],
[harfbuzz],
[http://harfbuzz.org/])
@@ -356,6 +356,30 @@ AM_CONDITIONAL(HAVE_UNISCRIBE, $have_uniscribe)
dnl ===========================================================================
+AC_ARG_WITH(directwrite,
+ [AS_HELP_STRING([--with-directwrite=@<:@yes/no/auto@:>@],
+ [Use the DirectWrite library (experimental) @<:@default=no@:>@])],,
+ [with_directwrite=no])
+have_directwrite=false
+AC_LANG_PUSH([C++])
+if test "x$with_directwrite" = "xyes" -o "x$with_directwrite" = "xauto"; then
+ AC_CHECK_HEADERS(dwrite.h, have_directwrite=true)
+fi
+AC_LANG_POP([C++])
+if test "x$with_directwrite" = "xyes" -a "x$have_directwrite" != "xtrue"; then
+ AC_MSG_ERROR([directwrite support requested but not found])
+fi
+if $have_directwrite; then
+ DIRECTWRITE_CXXFLAGS=
+ DIRECTWRITE_LIBS="-ldwrite"
+ AC_SUBST(DIRECTWRITE_CXXFLAGS)
+ AC_SUBST(DIRECTWRITE_LIBS)
+ AC_DEFINE(HAVE_DIRECTWRITE, 1, [Have DirectWrite library])
+fi
+AM_CONDITIONAL(HAVE_DIRECTWRITE, $have_directwrite)
+
+dnl ===========================================================================
+
AC_ARG_WITH(coretext,
[AS_HELP_STRING([--with-coretext=@<:@yes/no/auto@:>@],
[Use CoreText @<:@default=no@:>@])],,
@@ -444,6 +468,8 @@ test/fuzzing/Makefile
test/shaping/Makefile
docs/Makefile
docs/version.xml
+win32/Makefile
+win32/config.h.win32
])
AC_OUTPUT
@@ -470,6 +496,7 @@ Additional shapers (the more the better):
Platform shapers (not normally needed):
CoreText: ${have_coretext}
Uniscribe: ${have_uniscribe}
+ DirectWrite: ${have_directwrite}
Other features:
Documentation: ${have_gtk_doc}