summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2017-01-06 05:18:37 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2017-01-06 05:18:37 +0000
commit64caca9c0701991751d651c4c31f8dff6d97f449 (patch)
tree8067dae3900b2f4c6e62bb73c7369e87c83933e8 /Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
parent18c40a6c8865e922a9ef0277a06d1cde8e7caaad (diff)
harfbuzz 1.4.1
git-svn-id: svn://tug.org/texlive/trunk@42879 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/configure.ac')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
index 78869a99ecc..32dcf18ed28 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.64])
AC_INIT([HarfBuzz],
- [1.4.0],
+ [1.4.1],
[https://github.com/behdad/harfbuzz/issues/new],
[harfbuzz],
[http://harfbuzz.org/])
@@ -289,9 +289,13 @@ AM_CONDITIONAL(HAVE_ICU_BUILTIN, $have_icu && test "x$with_icu" = "xbuiltin")
dnl ===========================================================================
-have_ucdn=true
-if $have_glib || test \( $have_icu -a "x$with_icu" = "xbuiltin" \); then
- have_ucdn=false
+AC_ARG_WITH(ucdn,
+ [AS_HELP_STRING([--with-ucdn=@<:@yes/no@:>@],
+ [Use builtin UCDN library @<:@default=yes@:>@])],,
+ [with_ucdn=yes])
+have_ucdn=false
+if test "x$with_ucdn" = "xyes"; then
+ have_ucdn=true
fi
if $have_ucdn; then
AC_DEFINE(HAVE_UCDN, 1, [Have UCDN Unicode functions])
@@ -501,9 +505,9 @@ AC_MSG_NOTICE([
Build configuration:
Unicode callbacks (you want at least one):
+ Builtin (UCDN): ${have_ucdn}
Glib: ${have_glib}
ICU: ${have_icu}
- UCDN: ${have_ucdn}
Font callbacks (the more the better):
FreeType: ${have_freetype}