summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2021-09-18 03:14:52 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2021-09-18 03:14:52 +0000
commite354c4db8b5c1aca8742126417873e4bf6c635fb (patch)
tree36a521a144e6d5d3587b2ddc55b7d9d28df5db1b /Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt
parentcfc1866e8124fede8a6e5d0fb30923271c0aeaa1 (diff)
harfbuzz 3.0.0
git-svn-id: svn://tug.org/texlive/trunk@60533 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt b/Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt
index 37909190771..dee9a4678da 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.0.0)
+cmake_minimum_required(VERSION 3.1)
project(harfbuzz)
message(WARN "HarfBuzz has a Meson port and tries to migrate all the other build systems to it, please consider using it as we might remove our cmake port soon.")
@@ -102,9 +102,13 @@ if (${HAVE_STDBOOL_H})
add_definitions(-DHAVE_STDBOOL_H)
endif ()
-# https://github.com/harfbuzz/harfbuzz/pull/2874#issuecomment-782859099
-if (NOT WIN32)
- add_definitions("-DHAVE_PTHREAD")
+if (NOT MSVC)
+ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package(Threads)
+ if (CMAKE_USE_PTHREADS_INIT)
+ add_definitions("-DHAVE_PTHREAD")
+ list(APPEND THIRD_PARTY_LIBS Threads::Threads)
+ endif ()
endif ()
if (MSVC)