summaryrefslogtreecommitdiff
path: root/Build/source/libs/graphite2/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-12-04 13:11:31 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-12-04 13:11:31 +0000
commite820095ca870b45b0ce42d073f9eae53739b359c (patch)
treec1d334acc7439188c47976decd9788f38e11f98b /Build/source/libs/graphite2/configure.ac
parente42ad852910fa40560d1ee5b20dac7de0583a076 (diff)
libs/graphite2: Added for future XeTeX
git-svn-id: svn://tug.org/texlive/trunk@28442 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/graphite2/configure.ac')
-rw-r--r--Build/source/libs/graphite2/configure.ac63
1 files changed, 63 insertions, 0 deletions
diff --git a/Build/source/libs/graphite2/configure.ac b/Build/source/libs/graphite2/configure.ac
new file mode 100644
index 00000000000..0ccbb973f55
--- /dev/null
+++ b/Build/source/libs/graphite2/configure.ac
@@ -0,0 +1,63 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2012 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_include([version.ac])[] dnl define graphite2_version
+AC_INIT([graphite2 for TeX Live], graphite2_version, [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([graphite2-]graphite2_version[/graphite2.pc.in])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+AM_INIT_AUTOMAKE([foreign])
+AM_MAINTAINER_MODE
+
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_RANLIB
+AC_PROG_LN_S
+
+KPSE_COMPILER_WARNINGS
+
+LT_INIT
+
+AC_CONFIG_HEADERS([config.h])
+
+AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+
+if test "x$enable_build" != xno || test -f config.force; then
+echo timestamp >config.force
+fi
+
+AM_CONDITIONAL([DIRECT_TYPE], [test "x$GCC" = xyes])
+
+enable_segcache=no
+AM_CONDITIONAL([WITH_SEGCACHE], [test "x$enable_segcache" != xno])
+if test "x$enable_segcache" = no; then
+ AC_DEFINE([GRAPHITE2_NSEGCACHE], 1,
+ [Define to 1 to disable segcache support.])
+fi
+
+enable_fileface=yes
+AM_CONDITIONAL([WITH_FILEFACE], [test "x$enable_fileface" != xno])
+if test "x$enable_fileface" = no; then
+ AC_DEFINE([GRAPHITE2_NFILEFACE], 1,
+ [Define to 1 to disable fileface support.])
+fi
+
+enable_tracing=no
+AM_CONDITIONAL([WITH_TRACING], [test "x$enable_tracing" != xno])
+if test "x$enable_tracing" = no; then
+ AC_DEFINE([GRAPHITE2_NTRACING], 1,
+ [Define to 1 to disable tracing support.])
+fi
+
+AC_SUBST([GRAPHITE2_TREE], [graphite2-]graphite2_version)
+
+AC_CONFIG_FILES([Makefile include/graphite2/Makefile])
+
+AC_OUTPUT