summaryrefslogtreecommitdiff
path: root/Build/source/libs/graphite2/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-01-04 07:51:28 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-01-04 07:51:28 +0000
commit6cc553b4ef0a05f7d7af76d2e6eda6ff8c8ef76d (patch)
tree9ac5a0a6f68fdf28861fc21a9da9c2d27f5ad590 /Build/source/libs/graphite2/Makefile.am
parented939c48050228b2f793a43ae0dc3a247a1584e1 (diff)
graphite2: Add the required AM_CPP_FLAGS
Fix syntax of the test case for system graphite2 git-svn-id: svn://tug.org/texlive/trunk@28723 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/graphite2/Makefile.am')
-rw-r--r--Build/source/libs/graphite2/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Build/source/libs/graphite2/Makefile.am b/Build/source/libs/graphite2/Makefile.am
index 6b40b804112..507a1e61580 100644
--- a/Build/source/libs/graphite2/Makefile.am
+++ b/Build/source/libs/graphite2/Makefile.am
@@ -1,6 +1,6 @@
## Proxy Makefile.am to build graphite2 for TeX Live.
##
-## Copyright (C) 2012 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2012, 2013 Peter Breitenlohner <tex-live@tug.org>
##
## This file is free software; the copyright holder
## gives unlimited permission to copy and/or distribute it,
@@ -108,15 +108,21 @@ libgraphite2_a_SOURCES += \
$(GRAPHITE2_SRC)/SegCache.cpp \
$(GRAPHITE2_SRC)/SegCacheEntry.cpp \
$(GRAPHITE2_SRC)/SegCacheStore.cpp
-endif WITH_SEGCACHE
+else !WITH_SEGCACHE
+AM_CPPFLAGS += -DGRAPHITE2_NSEGCACHE
+endif !WITH_SEGCACHE
if WITH_FILEFACE
libgraphite2_a_SOURCES += $(GRAPHITE2_SRC)/FileFace.cpp
-endif WITH_FILEFACE
+else !WITH_FILEFACE
+AM_CPPFLAGS += -DGRAPHITE2_NFILEFACE
+endif !WITH_FILEFACE
if WITH_TRACING
libgraphite2_a_SOURCES += $(GRAPHITE2_SRC)/json.cpp
-endif WITH_TRACING
+else !WITH_TRACING
+AM_CPPFLAGS += -DGRAPHITE2_NTRACING
+endif !WITH_TRACING
$(libgraphite2_a_OBJECTS): config.force