summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-06-24 09:01:02 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-06-24 09:01:02 +0000
commitcd573af8ce5db24aae95c942b2ba505ca0a3338f (patch)
treeac38fcc8f72bccacd785ca6f74835e1f976334e1 /Build/source/libs/gd/configure.ac
parent6c998f4d3d5f21632bc1d2c87073afa9e6b9fc70 (diff)
gd 2.1.0-rc1 (libgd)
git-svn-id: svn://tug.org/texlive/trunk@30886 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/gd/configure.ac')
-rw-r--r--Build/source/libs/gd/configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/Build/source/libs/gd/configure.ac b/Build/source/libs/gd/configure.ac
index 3cf88d40444..5196227d566 100644
--- a/Build/source/libs/gd/configure.ac
+++ b/Build/source/libs/gd/configure.ac
@@ -1,15 +1,15 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2009-2011 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
dnl with or without modifications, as long as this notice is preserved.
dnl
-m4_define([gd_version], [2.0.35])[]dnl using unmodified gd source tree
+m4_include([version.ac])[] dnl define gd_version
AC_INIT([gd for TeX Live], gd_version, [tex-k@tug.org])
AC_PREREQ([2.65])
-AC_CONFIG_SRCDIR([gd-]gd_version[/gd.c])
+AC_CONFIG_SRCDIR([libgd-]gd_version[/src/gd.c])
AC_CONFIG_AUX_DIR([../../build-aux])
AC_CONFIG_MACRO_DIR([../../m4])
@@ -19,7 +19,7 @@ AC_PROG_CC
AC_PROG_RANLIB
AC_PROG_LN_S
-AC_CONFIG_HEADERS([config.h:config.hin])
+AC_CONFIG_HEADERS([config.h])
LT_PREREQ([2.2.6])
LT_INIT
@@ -68,7 +68,9 @@ AC_DEFINE([HAVE_PNG_H], 1)
AC_DEFINE([HAVE_LIBFREETYPE], 1, [ Define if you have the freetype library.])
AC_DEFINE([HAVE_FT2BUILD_H], 1)
-AC_SUBST([GD_TREE], [gd-]gd_version)
+AC_SUBST([GD_TREE], [libgd-]gd_version)
+
+KPSE_COND_WIN32
AC_CONFIG_FILES([Makefile include/Makefile])