summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2011-10-08 10:30:01 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2011-10-08 10:30:01 +0000
commit43d1252b0237bcc6ddfc784fd75075ed674c2c70 (patch)
tree659695c886887653dbcff8415501f2b88c9171e8 /Build/source/libs/gd/configure.ac
parent9d186ed8be36222a9f91b2b08b715442790f22ab (diff)
poppler 0.18.0
git-svn-id: svn://tug.org/texlive/trunk@24242 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/gd/configure.ac')
-rw-r--r--Build/source/libs/gd/configure.ac15
1 files changed, 6 insertions, 9 deletions
diff --git a/Build/source/libs/gd/configure.ac b/Build/source/libs/gd/configure.ac
index fb51f497881..6d6226f4484 100644
--- a/Build/source/libs/gd/configure.ac
+++ b/Build/source/libs/gd/configure.ac
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2009 - 2011 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright (C) 2009-2011 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
@@ -46,30 +46,27 @@ AM_CONDITIONAL([build], [test "x$enable_build" != xno])
if test "x$enable_build" != xno || test -f config.force; then
KPSE_ADD_FLAGS([zlib])
-
AC_CHECK_FUNC([deflate], , [AC_ERROR([zlib not found])])
AC_CHECK_HEADERS([zlib.h], , [AC_ERROR([zlib not found])])
-AC_DEFINE([HAVE_LIBZ], 1, [Define if you have zlib.])
KPSE_ADD_FLAGS([libpng])
-
AC_CHECK_FUNC([png_create_read_struct], , [AC_ERROR([libpng not found])])
AC_CHECK_HEADERS([png.h], , [AC_ERROR([libpng not found])])
-AC_DEFINE([HAVE_LIBPNG], 1, [Define if you have the png library.])
KPSE_ADD_FLAGS([freetype2])
-
AC_CHECK_FUNC([FT_Init_FreeType], , [AC_ERROR([libfreetype2 not found])])
AC_CHECK_HEADERS([ft2build.h], , [AC_ERROR([libfreetype2 not found])])
-AC_DEFINE([HAVE_LIBFREETYPE], 1, [ Define if you have the freetype library.])
KPSE_RESTORE_FLAGS
echo timestamp >config.force
fi
-GD_TREE=gd-[]gd_version
-AC_SUBST([GD_TREE])
+AC_DEFINE([HAVE_LIBZ], 1, [Define if you have zlib.])
+AC_DEFINE([HAVE_LIBPNG], 1, [Define if you have the png library.])
+AC_DEFINE([HAVE_LIBFREETYPE], 1, [ Define if you have the freetype library.])
+
+AC_SUBST([GD_TREE], [gd-]gd_version)
AC_CONFIG_FILES([Makefile include/Makefile])