summaryrefslogtreecommitdiff
path: root/Build/source/libs/gd/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-11-26 08:10:55 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-11-26 08:10:55 +0000
commit3c06d717b891d74b66f02b12ba0d4ad0f6437f5c (patch)
tree51bd46e7acd2ce72f2be14de4c9bfe854a47341c /Build/source/libs/gd/Makefile.am
parent6650155057159411fc2dddd0ae020266eb3509b5 (diff)
poppler: Require 0.20 or better for POPPLER_VERSION
build system: Better dependencies for parallel builds git-svn-id: svn://tug.org/texlive/trunk@28367 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/gd/Makefile.am')
-rw-r--r--Build/source/libs/gd/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Build/source/libs/gd/Makefile.am b/Build/source/libs/gd/Makefile.am
index 2cfc5e4bc81..7467539c065 100644
--- a/Build/source/libs/gd/Makefile.am
+++ b/Build/source/libs/gd/Makefile.am
@@ -14,9 +14,6 @@ rebuild: all
## We want to re-distribute the whole original libpng source tree.
##
-## With current automake (1.10.2) 'make distcheck' fails when
-## DISTFILES contains a directory and files in that directory.
-## Thus nodist_* for all files in $(GD_TREE).
EXTRA_DIST = $(GD_TREE)
## Changes applied to the original source tree
@@ -46,7 +43,7 @@ AM_CPPFLAGS += -DNONDLL
noinst_LIBRARIES=libgd.a
-nodist_libgd_a_SOURCES = \
+libgd_a_SOURCES = \
$(GD_TREE)/gd.c \
$(GD_TREE)/gd_gd.c \
$(GD_TREE)/gd_gd2.c \
@@ -78,14 +75,12 @@ nodist_libgd_a_SOURCES = \
$(libgd_a_OBJECTS): config.force
-config.force: $(ZLIB_DEPEND) $(LIBPNG_DEPEND) $(FREETYPE2_DEPEND)
+config.force: $(LIBPNG_DEPEND) $(FREETYPE2_DEPEND)
echo timestamp >config.force
$(SHELL) ./config.status --recheck
DISTCLEANFILES = config.force
-## Rebuild zlib
-@ZLIB_RULE@
## Rebuild libpng
@LIBPNG_RULE@
## Rebuild libfreetype