summaryrefslogtreecommitdiff
path: root/Build/source/libs/freetype2/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2018-12-22 14:44:13 +0000
committerKarl Berry <karl@freefriends.org>2018-12-22 14:44:13 +0000
commite246c1a36719fa89b7c182dfa7ec587005b43fff (patch)
tree3282e9156cd13d1e7e6159aaf753348383867d37 /Build/source/libs/freetype2/configure.ac
parent853cfdfff767236062bea73b9b3082d5266bf340 (diff)
always pass --build argument to freetype configure, if specified
git-svn-id: svn://tug.org/texlive/trunk@49476 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/freetype2/configure.ac')
-rw-r--r--Build/source/libs/freetype2/configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/Build/source/libs/freetype2/configure.ac b/Build/source/libs/freetype2/configure.ac
index a44a702f97e..cc55fbba7df 100644
--- a/Build/source/libs/freetype2/configure.ac
+++ b/Build/source/libs/freetype2/configure.ac
@@ -1,6 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright 2018 Karl Berry <tex-live@tug.org>
+dnl Copyright 2009-2013 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
@@ -19,14 +20,16 @@ AC_PROG_CC
AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+# pass explicit --host and --build, but nothing else?
if test "x$host" = x; then
config_args=
else
config_args="--host=$host"
- if test "x$build" != x; then
- config_args="$config_args --build=$build"
- fi
fi
+if test "x$build" != x; then
+ config_args="$config_args --build=$build"
+fi
+
AC_SUBST([config_args])
AC_SUBST([FREETYPE_TREE], [freetype-src])