summaryrefslogtreecommitdiff
path: root/Build/source/libs/configure.in
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2006-01-16 00:09:26 +0000
committerKarl Berry <karl@freefriends.org>2006-01-16 00:09:26 +0000
commit6c0eafbb1395d426a72a74538e0b2a95e8344ca6 (patch)
tree2a5f80b80fc76086a2602b812c2a182d00f961b7 /Build/source/libs/configure.in
parent70f7efeb5c9965a63a4143ad1c1f473585dc364c (diff)
libs 1
git-svn-id: svn://tug.org/texlive/trunk@1483 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/configure.in')
-rw-r--r--Build/source/libs/configure.in60
1 files changed, 60 insertions, 0 deletions
diff --git a/Build/source/libs/configure.in b/Build/source/libs/configure.in
new file mode 100644
index 00000000000..638c19751ce
--- /dev/null
+++ b/Build/source/libs/configure.in
@@ -0,0 +1,60 @@
+AC_INIT(EXTRA.LIB)
+
+AC_CONFIG_AUX_DIR(../config)
+AC_SET_MAKE
+AC_PROG_CC
+AC_CANONICAL_SYSTEM
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+AC_PROG_LN_S
+AC_FUNC_ALLOCA
+AC_PROG_RANLIB
+AM_MAINTAINER_MODE
+
+sinclude(../texk/kpathsea/withenable.ac)
+sinclude(t1lib/withenable.ac)
+sinclude(t1lib/t1lib.ac)
+sinclude(ncurses/withenable.ac)
+sinclude(ncurses/ncurses.ac)
+sinclude(libpng/withenable.ac)
+sinclude(libpng/libpng.ac)
+sinclude(zlib/withenable.ac)
+sinclude(zlib/zlib.ac)
+sinclude(gd/withenable.ac)
+sinclude(gd/gd.ac)
+sinclude(freetype/withenable.ac)
+sinclude(freetype/freetype.ac)
+
+# The following line helps, e.g. for ncurses which properly detects the
+# system's terminfo definitions if configured without explicit --prefix.
+# ac_configure_args=`echo "$ac_configure_args" | sed 's@--prefix=[[^ ]]*@@'`
+
+if test "x$needs_libt1" != xno && test "$using_system_t1lib" != yes; then
+ AC_CONFIG_SUBDIRS([t1lib type1])
+fi
+if test "x$needs_ncurses" != xno && test "$using_system_ncurses" != yes; then
+ AC_CONFIG_SUBDIRS([ncurses])
+fi
+if test "x$needs_libxpdf" != xno; then
+ AC_CONFIG_SUBDIRS([xpdf])
+fi
+if test "x$needs_freetype" != xno && test "$using_system_freetype" != yes; then
+ AC_CONFIG_SUBDIRS([freetype])
+fi
+if test "x$needs_gd" != xno && test "$using_system_gd" != yes; then
+ AC_CONFIG_SUBDIRS([gd])
+fi
+
+if test "x$needs_pnglib" != xno && test "$using_system_pnglib" != yes; then
+ KPSE_CONFIG_FILES([libpng/Makefile])
+fi
+if test "x$needs_zlib" != xno && test "$using_system_zlib" != yes; then
+ KPSE_CONFIG_FILES([zlib/Makefile])
+fi
+
+# create md5 directory when building outside the srcdir:
+if test -d $srcdir/md5; then
+ test -d md5 || mkdir md5
+fi
+
+AC_OUTPUT