summaryrefslogtreecommitdiff
path: root/Build/source/libs/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-09-09 10:07:08 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-09-09 10:07:08 +0000
commite981cdbd1662ed82436259f1046987c5b7204f1a (patch)
tree031a0f1bd753e2495237b10de7d1ff6fe5a1a909 /Build/source/libs/configure.ac
parent3ad3db6624b55ad14658410f68ab6cb878904c7c (diff)
Various updates of build system: Use AC_CONFIG_MACRO_DIRS instead of ACLOCAL_AMFLAGS,
Factor recursion into subdirs into .am fragment and m4 macros, Avoid unnecessary use of Libtool, Use z_const git-svn-id: svn://tug.org/texlive/trunk@31606 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/configure.ac')
-rw-r--r--Build/source/libs/configure.ac23
1 files changed, 2 insertions, 21 deletions
diff --git a/Build/source/libs/configure.ac b/Build/source/libs/configure.ac
index 998adeca666..782b3ca17be 100644
--- a/Build/source/libs/configure.ac
+++ b/Build/source/libs/configure.ac
@@ -11,7 +11,7 @@ AC_INIT([TeX Live libs], tex_live_version(), [tex-k@tug.org])
AC_PREREQ([2.65])
AC_CONFIG_SRCDIR([../build-aux/missing])
AC_CONFIG_AUX_DIR([../build-aux])
-AC_CONFIG_MACRO_DIR([../m4])
+AC_CONFIG_MACRO_DIRS([../m4])
dnl See comment in ../configure.ac
KPSE_SETUP([../])
@@ -20,26 +20,7 @@ KPSE_BASIC([libs])
AC_PROG_MKDIR_P
-AC_MSG_CHECKING([for generic libraries to build])
-MAKE_SUBDIRS=
-CONF_SUBDIRS=
-KPSE_FOR_PKGS([libs], [
-if test -x $srcdir/Kpse_Pkg/configure; then
- if test "x$with_system_[]Kpse_pkg" != xyes && \
- test "x$need_[]Kpse_pkg" = xyes; then
- MAKE_SUBDIRS="Kpse_Pkg $MAKE_SUBDIRS"
- fi
-dnl Cause 'make dist' to recurse into all sublibs dirs
- CONF_SUBDIRS="Kpse_Pkg $CONF_SUBDIRS"
-dnl Cause 'configure -hr' and 'autoreconf' to recurse into all sublibs dirs
- if false; then
- AC_CONFIG_SUBDIRS(Kpse_Pkg)
- fi
-fi
-])
-AC_SUBST([MAKE_SUBDIRS])
-AC_SUBST([CONF_SUBDIRS])
-AC_MSG_RESULT([$MAKE_SUBDIRS])
+KPSE_RECURSE_LIBS([libs], [generic])
AC_CONFIG_FILES([Makefile])